summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-12-14 20:49:11 +0100
committermirandir2015-12-14 20:49:11 +0100
commiteb28d9f322bf746bd2cefe77840c606eef7fea21 (patch)
treea5d58dbe49e41a7efc626d0377366baeb92bf608
parent1c540082eb99e7e64dd90469067f3587f70399a3 (diff)
downloadaur-eb28d9f322bf746bd2cefe77840c606eef7fea21.tar.gz
Removes patches already integrated upstream
-rw-r--r--.SRCINFO12
-rw-r--r--NetPacket_buffer_size.patch23
-rw-r--r--PKGBUILD15
-rw-r--r--format-security.patch14
-rw-r--r--makefile.patch32
-rw-r--r--no-springs.patch26
6 files changed, 6 insertions, 116 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e00f4d075ae3..4e298b11c504 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jumpnbump
pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port.
pkgver = 1.60
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MCMic/jumpnbump
arch = i686
arch = x86_64
@@ -11,18 +11,10 @@ pkgbase = jumpnbump
depends = sdl2_net
optdepends = jumpnbump-levels: more levels for jumpnbump
optdepends = jumpnbump-menu: a launcher for jumpnbump
- source = jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=28fc03e
- source = makefile.patch
- source = format-security.patch
- source = no-springs.patch
+ source = jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=0785e55
source = safe-temporary-files.patch
- source = NetPacket_buffer_size.patch
sha256sums = SKIP
- sha256sums = 68b8df05a9f3cb6fa4584570c0558cdd23e43bc822fd8a53d708900bdc23ef01
- sha256sums = c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290
- sha256sums = c6d795f3c5d0a174dfe6f2e528d70246d75181ffa3f652386c2f8b2b84657ce9
sha256sums = f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c
- sha256sums = 521317ed06d957fb0e3a509e93976ec52709e6f2a16ea121d3767f871605a485
pkgname = jumpnbump
diff --git a/NetPacket_buffer_size.patch b/NetPacket_buffer_size.patch
deleted file mode 100644
index 1959be8626a6..000000000000
--- a/NetPacket_buffer_size.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Subject: Fix NetPacket buffer size by adapting its member types
-Author: Fabian Greffrath <fabian+debian@greffrath.com>
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762698
-
---- network.h.orig 2015-12-13 02:08:25.346244000 +0100
-+++ network.h 2015-12-13 02:09:56.248672920 +0100
-@@ -51,11 +51,11 @@
-
- typedef struct
- {
-- unsigned long cmd;
-- long arg;
-- long arg2;
-- long arg3;
-- long arg4;
-+ Uint32 cmd;
-+ Sint32 arg;
-+ Sint32 arg2;
-+ Sint32 arg3;
-+ Sint32 arg4;
- } NetPacket;
-
- void processMovePacket(NetPacket *pkt);
diff --git a/PKGBUILD b/PKGBUILD
index d8bd56d1caf8..e274822f59d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,21 @@
pkgname=jumpnbump
pkgver=1.60
-pkgrel=2
+pkgrel=3
pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port."
arch=('i686' 'x86_64')
url="https://github.com/MCMic/jumpnbump"
license=('GPL')
depends=('sdl2' 'sdl2_mixer' 'sdl2_net')
optdepends=('jumpnbump-levels: more levels for jumpnbump' 'jumpnbump-menu: a launcher for jumpnbump')
-source=(jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=28fc03e makefile.patch format-security.patch no-springs.patch safe-temporary-files.patch NetPacket_buffer_size.patch)
+source=(jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=0785e55 safe-temporary-files.patch)
sha256sums=('SKIP'
- '68b8df05a9f3cb6fa4584570c0558cdd23e43bc822fd8a53d708900bdc23ef01'
- 'c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290'
- 'c6d795f3c5d0a174dfe6f2e528d70246d75181ffa3f652386c2f8b2b84657ce9'
- 'f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c'
- '521317ed06d957fb0e3a509e93976ec52709e6f2a16ea121d3767f871605a485')
+ 'f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c')
build() {
cd "${srcdir}/${pkgname}/"
- patch -lp0 < ${srcdir}/makefile.patch
- patch -lp0 < ${srcdir}/no-springs.patch
- patch -lp0 < ${srcdir}/NetPacket_buffer_size.patch
- for i in 'format-security.patch' 'safe-temporary-files.patch'
+ for i in 'safe-temporary-files.patch'
do
patch -p1 < ${srcdir}/$i
done
diff --git a/format-security.patch b/format-security.patch
deleted file mode 100644
index 4506b744e843..000000000000
--- a/format-security.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Subject: Fix format-security vulnerability
-Author: Fabian Greffrath <fabian+debian@greffrath.com>
-
---- a/main.c
-+++ b/main.c
-@@ -3400,7 +3400,7 @@ void deinit_program(void)
- #endif
-
- if (main_info.error_str[0] != 0) {
-- printf(main_info.error_str);
-+ printf("%s", main_info.error_str);
- #ifdef _MSC_VER
- MessageBox(0, main_info.error_str, "Jump'n'Bump", 0);
- #endif
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index 6dcf6a9cb420..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- Makefile.orig 2015-12-14 13:43:24.760324000 +0100
-+++ Makefile 2015-12-14 13:47:51.211541498 +0100
-@@ -10,7 +10,7 @@
- TARGET = jumpnbump
- BINARIES = $(TARGET) jumpnbump.svgalib jumpnbump.fbcon $(MODIFY_TARGET) \
- jnbmenu.tcl
--PREFIX ?= /usr/local
-+PREFIX ?= /usr/
-
- .PHONY: data
-
-@@ -43,16 +43,16 @@
- rm -f $(TARGET) *.o globals.h jnbmenu.tcl
-
- install:
-- mkdir -p $(PREFIX)/games/
-+ mkdir -p $(PREFIX)/bin/
- mkdir -p $(PREFIX)/share/jumpnbump/
- mkdir -p $(PREFIX)/share/man/man6/
-- install -o root -g games -m 755 $(BINARIES) $(PREFIX)/games/
-- install -o root -g games -m 644 data/jumpbump.dat \
-+ install -o root -g root -m 755 $(BINARIES) $(PREFIX)/bin/
-+ install -o root -g root -m 644 data/jumpbump.dat \
- $(PREFIX)/share/jumpnbump/jumpbump.dat
- install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/share/man/man6/
-
- uninstall:
-- cd $(PREFIX)/games && rm -f $(BINARIES)
-+ cd $(PREFIX)/bin/ && rm -f $(BINARIES)
- rm -rf $(PREFIX)/share/jumpnbump
- rm -f $(PREFIX)/share/man/man6/jumpnbump.6
-
diff --git a/no-springs.patch b/no-springs.patch
deleted file mode 100644
index 468cd211a5b7..000000000000
--- a/no-springs.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 4a0a965547b52afc953d9bd11ab059f543551459 Mon Sep 17 00:00:00 2001
-From: Fabian Greffrath <fabian@greffrath.com>
-Date: Tue, 16 Sep 2014 19:02:37 +0200
-Subject: [PATCH] fix rabbit disappearing in upper left corner
-
-aka "undesired springs added above the screen"
-
-If the bunny jumps out of the screen, its
-y-coordinate becomes negative. Thus, the array that is checked for the
-position of the objects on the map overflows and returns some bogus,
-e.g. that there are springs whereas there aren't. This patch
-checks for the y-coordinate and caps it at zero.
-
-c.f. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370650
-
---- main.c.orig 2015-12-12 14:28:44.122453000 +0100
-+++ main.c 2015-12-12 14:35:47.141659120 +0100
-@@ -1365,6 +1365,8 @@
-
- s1 = (player[c1].x >> 16);
- s2 = (player[c1].y >> 16);
-+ if (s2 < 0)
-+ s2 = 0;
- if (GET_BAN_MAP_XY((s1 + 8), (s2 + 15)) == BAN_SPRING || ((GET_BAN_MAP_XY(s1, (s2 + 15)) == BAN_SPRING && GET_BAN_MAP_XY((s1 + 15), (s2 + 15)) != BAN_SOLID) || (GET_BAN_MAP_XY(s1, (s2 + 15)) != BAN_SOLID && GET_BAN_MAP_XY((s1 + 15), (s2 + 15)) == BAN_SPRING))) {
- player[c1].y = ((player[c1].y >> 16) & 0xfff0) << 16;
- player[c1].y_add = -400000L;