summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-12-14 09:45:12 +0100
committermirandir2015-12-14 09:45:12 +0100
commitff28187dd67f5a7c96203556513db7d7ad150ef3 (patch)
tree0a2fbc283c27c6b2164eedf839b530dfe5ed4534
parent694fb3bcfa1cb991f7ffd43e8cdfd42947e5cfbf (diff)
downloadaur-ff28187dd67f5a7c96203556513db7d7ad150ef3.tar.gz
Updated to a new SDL2 port of the game
-rw-r--r--.SRCINFO35
-rw-r--r--NetPacket_buffer_size.patch12
-rw-r--r--PKGBUILD51
-rw-r--r--exit-fullscreen.patch43
-rw-r--r--handle-SDL-quit-event.patch21
-rw-r--r--jnb.patch34
-rw-r--r--makefile.patch40
-rw-r--r--no-springs.patch26
-rw-r--r--remove-XF86Config-information.patch19
-rw-r--r--remove-outdated-network-info.patch25
10 files changed, 85 insertions, 221 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b92ebac12f65..87d1cfd88798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,28 @@
pkgbase = jumpnbump
- pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign.
- pkgver = 1.55
- pkgrel = 6
- url = http://freecode.com/projects/jumpnbump
+ pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port.
+ pkgver = 1.60
+ pkgrel = 1
+ url = https://github.com/MCMic/jumpnbump
arch = i686
arch = x86_64
license = GPL
- depends = sdl_mixer
- depends = sdl_net
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = sdl2_net
optdepends = jumpnbump-levels: more levels for jumpnbump
optdepends = jumpnbump-menu: a launcher for jumpnbump
- source = http://mirandir.pagesperso-orange.fr/files/jumpnbump-1.55.tar.gz
- source = jnb.patch
- source = exit-fullscreen.patch
+ source = jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=28fc03e
+ source = makefile.patch
source = format-security.patch
- source = handle-SDL-quit-event.patch
- source = NetPacket_buffer_size.patch
source = no-springs.patch
- source = remove-outdated-network-info.patch
- source = remove-XF86Config-information.patch
source = safe-temporary-files.patch
- sha256sums = 95e9ec8c3148a996bd46ffea21393aa0e0868706325d5947bc932b4ba46eafcf
- sha256sums = 16d4363944d8279e7da77588085f7c103afa743f977c1ea9c742959f6140253d
- sha256sums = dd8477ce5cb52de888d5e05290f3773550aabe6a213010981b9678b119efedbc
+ source = NetPacket_buffer_size.patch
+ sha256sums = SKIP
+ sha256sums = deaaa6b6ffbeca4988cbe140c1099073b0939c9665f3092c865a3185b1eafcb8
sha256sums = c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290
- sha256sums = c8ae29440efdadbc219cb2157912342a1c44ba1456407163156df0bba5e63959
- sha256sums = c1ba56fbb95495cdc2212e0dd3a67e572894785c2e8efe2629324d7c5a1ea8a2
- sha256sums = a06d0cb309e985e3ba78dd8495955b83805e67f43906634d7e782f0580b5343a
- sha256sums = dcaadc60cf7210ec5ed87a630a7da2856b6ab483f2ea6608bc07c120bb55140b
- sha256sums = 17877cafcd9d8440a0f2c9e8da80136a9c4c5eeebb633e7dd748a05cd0d1b6e0
+ sha256sums = 9abb6eacbdc964575de1219467e376737c2d67b79c43c0ac8f2a17ab55cfea2c
sha256sums = f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c
+ sha256sums = db10c56f0183177e02da83e4277b4cff4637b67a8a354fa7981a519a90ee7ba9
pkgname = jumpnbump
diff --git a/NetPacket_buffer_size.patch b/NetPacket_buffer_size.patch
index 7356401b0520..cecb1d9ec384 100644
--- a/NetPacket_buffer_size.patch
+++ b/NetPacket_buffer_size.patch
@@ -1,10 +1,6 @@
-Subject: Fix NetPacket buffer size by adapting its member types
-Author: Fabian Greffrath <fabian+debian@greffrath.com>
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762698
-
---- a/main.c
-+++ b/main.c
-@@ -273,11 +273,11 @@ NetInfo net_info[JNB_MAX_PLAYERS];
+--- network.h.orig 2015-12-13 02:08:25.346244000 +0100
++++ network.h 2015-12-13 02:09:56.248672920 +0100
+@@ -51,11 +51,11 @@
typedef struct
{
@@ -20,4 +16,4 @@ Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762698
+ Sint32 arg4;
} NetPacket;
- #define NETPKTBUFSIZE (4 + 4 + 4 + 4 + 4)
+ void processMovePacket(NetPacket *pkt);
diff --git a/PKGBUILD b/PKGBUILD
index 991f3f71828f..3990e0615412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,47 +3,42 @@
# Maintainer: mirandir <mirandir[AT]orange[DOT]fr>
pkgname=jumpnbump
-pkgver=1.55
-pkgrel=6
-pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign."
+pkgver=1.60
+pkgrel=1
+pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port."
arch=('i686' 'x86_64')
-url="http://freecode.com/projects/jumpnbump"
+url="https://github.com/MCMic/jumpnbump"
license=('GPL')
-depends=('sdl_mixer' 'sdl_net')
+depends=('sdl2' 'sdl2_mixer' 'sdl2_net')
optdepends=('jumpnbump-levels: more levels for jumpnbump' 'jumpnbump-menu: a launcher for jumpnbump')
-source=("http://mirandir.pagesperso-orange.fr/files/${pkgname}-${pkgver}.tar.gz" "jnb.patch" "exit-fullscreen.patch" "format-security.patch" "handle-SDL-quit-event.patch" "NetPacket_buffer_size.patch" "no-springs.patch" "remove-outdated-network-info.patch" "remove-XF86Config-information.patch" "safe-temporary-files.patch")
-sha256sums=('95e9ec8c3148a996bd46ffea21393aa0e0868706325d5947bc932b4ba46eafcf'
- '16d4363944d8279e7da77588085f7c103afa743f977c1ea9c742959f6140253d'
- 'dd8477ce5cb52de888d5e05290f3773550aabe6a213010981b9678b119efedbc'
+source=(jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=28fc03e makefile.patch format-security.patch no-springs.patch safe-temporary-files.patch NetPacket_buffer_size.patch)
+sha256sums=('SKIP'
+ 'deaaa6b6ffbeca4988cbe140c1099073b0939c9665f3092c865a3185b1eafcb8'
'c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290'
- 'c8ae29440efdadbc219cb2157912342a1c44ba1456407163156df0bba5e63959'
- 'c1ba56fbb95495cdc2212e0dd3a67e572894785c2e8efe2629324d7c5a1ea8a2'
- 'a06d0cb309e985e3ba78dd8495955b83805e67f43906634d7e782f0580b5343a'
- 'dcaadc60cf7210ec5ed87a630a7da2856b6ab483f2ea6608bc07c120bb55140b'
- '17877cafcd9d8440a0f2c9e8da80136a9c4c5eeebb633e7dd748a05cd0d1b6e0'
- 'f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c')
+ '9abb6eacbdc964575de1219467e376737c2d67b79c43c0ac8f2a17ab55cfea2c'
+ 'f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c'
+ 'db10c56f0183177e02da83e4277b4cff4637b67a8a354fa7981a519a90ee7ba9')
build() {
- cd "${srcdir}/${pkgname}-1.50/"
+ cd "${srcdir}/${pkgname}/"
+ patch -lp0 < ${srcdir}/makefile.patch
+ patch -lp0 < ${srcdir}/no-springs.patch
+ patch -lp0 < ${srcdir}/NetPacket_buffer_size.patch
- for i in 'exit-fullscreen.patch' 'format-security.patch' 'handle-SDL-quit-event.patch' 'NetPacket_buffer_size.patch' 'no-springs.patch' 'remove-outdated-network-info.patch' 'remove-XF86Config-information.patch' 'safe-temporary-files.patch'
+ for i in 'format-security.patch' 'safe-temporary-files.patch'
do
patch -p1 < ${srcdir}/$i
done
- cd "${srcdir}/${pkgname}-1.50/sdl/"
- patch -lp0 < ../../jnb.patch || return 1
-
- cd "${srcdir}/${pkgname}-1.50"
-
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man
-
make
}
package() {
- cd "${srcdir}/${pkgname}-1.50"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}"
+ make PREFIX="${pkgdir}" install
+
+ install -d $pkgdir/usr/lib/jumpnbump
+ mv $pkgdir/usr/bin/gobpack $pkgdir/usr/lib/jumpnbump/gobpack
+ mv $pkgdir/usr/bin/jnbpack $pkgdir/usr/lib/jumpnbump/pack
+ mv $pkgdir/usr/bin/jnbunpack $pkgdir/usr/lib/jumpnbump/unpack
}
diff --git a/exit-fullscreen.patch b/exit-fullscreen.patch
deleted file mode 100644
index 63be971d7b1d..000000000000
--- a/exit-fullscreen.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Subject: Exit fullscreen mode on quit
-From: Dan Carpenter <error27@gmail.com>
-Date: Tue, 17 Jan 2006 08:37:51 -0800
-
-See http://bugs.debian.org/338705
-
---- a/globals.h
-+++ b/globals.h
-@@ -344,6 +344,7 @@ void register_mask(void *pixels);
- #ifdef USE_SDL
- /* long filelength(int handle); */
- void fs_toggle();
-+void exit_fullscreen();
- int intr_sysupdate();
- #endif
-
---- a/main.c
-+++ b/main.c
-@@ -3375,6 +3375,8 @@ void deinit_program(void)
- __dpmi_regs regs;
- #endif
-
-+ exit_fullscreen();
-+
- dj_stop();
- dj_free_mod(MOD_MENU);
- dj_free_mod(MOD_GAME);
---- a/sdl/gfx.c
-+++ b/sdl/gfx.c
-@@ -227,6 +227,13 @@ void fs_toggle()
- }
-
-
-+void exit_fullscreen()
-+{
-+ if (fullscreen)
-+ fs_toggle();
-+}
-+
-+
- void wait_vrt(int mix)
- {
- return;
diff --git a/handle-SDL-quit-event.patch b/handle-SDL-quit-event.patch
deleted file mode 100644
index d542c374337b..000000000000
--- a/handle-SDL-quit-event.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Subject: Handle SQL quit event
-From: Ansgar Burchardt <ansgar@43-1.org>
-Date: Sat Dec 13 15:00:01 2008 +0100
-
-This patch makes Jump'n'bump quit when pressing the close button or
-using other means to ask Jump'n'bump to quit (e.g. Alt+F4).
-
-Closes: #487333
-
---- a/sdl/interrpt.c
-+++ b/sdl/interrpt.c
-@@ -419,6 +419,9 @@ int intr_sysupdate()
- break;
- }
- break;
-+ case SDL_QUIT:
-+ deinit_program();
-+ break;
- default:
- break;
- }
diff --git a/jnb.patch b/jnb.patch
deleted file mode 100644
index 2daf45f6d367..000000000000
--- a/jnb.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- interrpt.c.orig 2004-06-16 21:03:39.000000000 +0200
-+++ interrpt.c 2014-09-12 11:11:21.197959171 +0200
-@@ -369,6 +369,7 @@
- }
- break;
- case SDLK_1:
-+ case SDLK_AMPERSAND:
- if (e.type == SDL_KEYUP)
- ai[0] = !ai[0];
-
-@@ -378,6 +379,7 @@
- addkey((KEY_PL1_JUMP & 0x7f) | 0x8000);
- break;
- case SDLK_2:
-+ case SDLK_WORLD_73:
- if (e.type == SDL_KEYUP)
- ai[1] = !ai[1];
-
-@@ -387,6 +389,7 @@
- addkey((KEY_PL2_JUMP & 0x7f) | 0x8000);
- break;
- case SDLK_3:
-+ case SDLK_QUOTEDBL:
- if (e.type == SDL_KEYUP)
- ai[2] = !ai[2];
-
-@@ -396,6 +399,7 @@
- addkey((KEY_PL3_JUMP & 0x7f) | 0x8000);
- break;
- case SDLK_4:
-+ case SDLK_QUOTE:
- if (e.type == SDL_KEYUP)
- ai[3] = !ai[3];
-
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..551d615275d5
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,40 @@
+--- Makefile.orig 2015-12-12 12:31:26.850930000 +0100
++++ Makefile 2015-12-12 12:33:25.507572377 +0100
+@@ -10,7 +10,7 @@
+ TARGET = jumpnbump
+ BINARIES = $(TARGET) jumpnbump.svgalib jumpnbump.fbcon $(MODIFY_TARGET) \
+ jnbmenu.tcl
+-PREFIX ?= /usr/local
++PREFIX ?= /usr/
+
+ .PHONY: data
+
+@@ -43,18 +43,18 @@
+ rm -f $(TARGET) *.o globals.h jnbmenu.tcl
+
+ install:
+- mkdir -p $(PREFIX)/games/
+- mkdir -p $(PREFIX)/share/jumpnbump/
+- mkdir -p $(PREFIX)/share/man/man6/
+- install -o root -g games -m 755 $(BINARIES) $(PREFIX)/games/
+- install -o root -g games -m 644 data/jumpbump.dat \
+- $(PREFIX)/share/jumpnbump/jumpbump.dat
+- install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/share/man/man6/
++ mkdir -p $(PREFIX)/usr/bin/
++ mkdir -p $(PREFIX)/usr/share/jumpnbump/
++ mkdir -p $(PREFIX)/usr/share/man/man6/
++ install -o root -g root -m 755 $(BINARIES) $(PREFIX)/usr/bin/
++ install -o root -g root -m 644 data/jumpbump.dat \
++ $(PREFIX)/usr/share/jumpnbump/jumpbump.dat
++ install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/usr/share/man/man6/
+
+ uninstall:
+- cd $(PREFIX)/games && rm -f $(BINARIES)
+- rm -rf $(PREFIX)/share/jumpnbump
+- rm -f $(PREFIX)/share/man/man6/jumpnbump.6
++ cd $(PREFIX)/usr/bin/ && rm -f $(BINARIES)
++ rm -rf $(PREFIX)/usr/share/jumpnbump
++ rm -f $(PREFIX)/usr/share/man/man6/jumpnbump.6
+
+ doc:
+ rman jumpnbump.6 -f HTML >jumpnbump.html
diff --git a/no-springs.patch b/no-springs.patch
index f5086a21e681..0e0c4ec9f823 100644
--- a/no-springs.patch
+++ b/no-springs.patch
@@ -1,29 +1,11 @@
-From 4a0a965547b52afc953d9bd11ab059f543551459 Mon Sep 17 00:00:00 2001
-From: Fabian Greffrath <fabian@greffrath.com>
-Date: Tue, 16 Sep 2014 19:02:37 +0200
-Subject: [PATCH] fix rabbit disappearing in upper left corner
-
-aka "undesired springs added above the screen"
-
-If the bunny jumps out of the screen, its
-y-coordinate becomes negative. Thus, the array that is checked for the
-position of the objects on the map overflows and returns some bogus,
-e.g. that there are springs whereas there aren't. This patch
-checks for the y-coordinate and caps it at zero.
-
-c.f. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370650
----
- main.c | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/main.c
-+++ b/main.c
-@@ -2096,6 +2096,8 @@ void steer_players(void)
+--- main.c.orig 2015-12-12 14:28:44.122453000 +0100
++++ main.c 2015-12-12 14:35:47.141659120 +0100
+@@ -1365,6 +1365,8 @@
s1 = (player[c1].x >> 16);
s2 = (player[c1].y >> 16);
+ if (s2 < 0)
+ s2 = 0;
- if (ban_map[(s2 + 15) >> 4][(s1 + 8) >> 4] == BAN_SPRING || ((ban_map[(s2 + 15) >> 4][s1 >> 4] == BAN_SPRING && ban_map[(s2 + 15) >> 4][(s1 + 15) >> 4] != BAN_SOLID) || (ban_map[(s2 + 15) >> 4][s1 >> 4] != BAN_SOLID && ban_map[(s2 + 15) >> 4][(s1 + 15) >> 4] == BAN_SPRING))) {
+ if (GET_BAN_MAP_XY((s1 + 8), (s2 + 15)) == BAN_SPRING || ((GET_BAN_MAP_XY(s1, (s2 + 15)) == BAN_SPRING && GET_BAN_MAP_XY((s1 + 15), (s2 + 15)) != BAN_SOLID) || (GET_BAN_MAP_XY(s1, (s2 + 15)) != BAN_SOLID && GET_BAN_MAP_XY((s1 + 15), (s2 + 15)) == BAN_SPRING))) {
player[c1].y = ((player[c1].y >> 16) & 0xfff0) << 16;
player[c1].y_add = -400000L;
diff --git a/remove-XF86Config-information.patch b/remove-XF86Config-information.patch
deleted file mode 100644
index 2e11fd82a280..000000000000
--- a/remove-XF86Config-information.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Subject: Remove modeline for XF86Config-4 from README
-
---- a/README
-+++ b/README
-@@ -24,14 +24,6 @@ Thanks to ben for making patches to run
- Thanks to ivo for doing debian packages.
-
- f10 change between windowed/fullscreen mode
--(see the XF86Config-4, copy n paste the modeline 400x256
--then add the mode "400x256" to whatever bpp you have by default, restart x)
--example: add following line in Section "Monitor" of your
--/etc/X11/XF86Config (or XF86Config-4)
--Modeline "400x256" 22.00 400 416 480 504 256 259 262 269 doublescan
--then in Section "Screen" if your DefaultDepth is 24 do be sure you have
--something like:
--Modes "1024x768" "640x480" "512x384" "400x256" "320x240"
- esc/f12 exit
-
- For compilation you will need:
diff --git a/remove-outdated-network-info.patch b/remove-outdated-network-info.patch
deleted file mode 100644
index e955be0ceca0..000000000000
--- a/remove-outdated-network-info.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Subject: Remove outdated network information from README
-From: Francois Marier <francois@debian.org>
-Date: Sun, 26 Jun 2005 13:02:29 -0400
-
-See http://bugs.debian.org/314221.
-
---- a/README
-+++ b/README
-@@ -44,16 +44,6 @@ which you can start with: jumpnbump -dat
- there's a screensaver mode as well:
- jumpnbump -fireworks -fullscreen
-
--Network play works like this, oh well here's an example
--Player 1: jumpnbump -port 7777 -net 0 ip_or_hostname_of_player2 port_of_player2
--Player 2: jumpnbump -port 7777 -net 1 ip_or_hostname_of_player1 port_of_player1
--just take port 7777 for all ports and hope it's open and you aren't
--firewalled (it's all udp!)
--You can add -net 3 and -net 4 for 3rd and 4th player, and be sure.
--All the players use the same -dat level.dat
--(the scoreboards is different on each player and strange things like
--that, but longislandman is working on it (isn't it? longislandman? you alive?))
--
- You can find the original dos game (which runs in dos/win9x (dosextender!))
- at http://www.brainchilddesign.com/games/jumpnbump/index.html
-