summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-05-24 18:19:48 +0800
committerdetiam2023-05-24 18:19:48 +0800
commitc1f9f9eef0455bd54c06cfd75d07bfd7015100ec (patch)
treeb3b3eb3ca87434dc20abd4070443ace40f62abbd
downloadaur-c1f9f9eef0455bd54c06cfd75d07bfd7015100ec.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9213f7796b1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = junction-zhfix
+ pkgdesc = Application/browser chooser
+ pkgver = 1.6
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/sonnyp/Junction
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = python-gobject
+ makedepends = blueprint-compiler
+ depends = libadwaita
+ depends = libportal-gtk4
+ depends = gjs
+ source = junction-1.6::git+https://github.com/sonnyp/Junction.git#tag=v1.6
+ source = git+https://github.com/sonnyp/troll.git#commit=fb2d7f26233cea295b23215fd38ecf12a02dbbd0
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = junction-zhfix
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4df5cbd2d036
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba9116629bd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: detiam <dehe_tian@outlook.com>
+# Contributor: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+_pkgname=junction
+pkgname=junction-zhfix
+pkgver=1.6
+_tag=v$pkgver
+_trollcommit=fb2d7f26233cea295b23215fd38ecf12a02dbbd0
+pkgrel=1
+epoch=0
+pkgdesc="Application/browser chooser"
+arch=('x86_64')
+url="https://github.com/sonnyp/Junction"
+license=('GPL3')
+depends=('libadwaita' 'libportal-gtk4' 'gjs')
+makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler')
+checkdepends=('appstream-glib')
+source=("${_pkgname}-${pkgver}::git+$url.git#tag=$_tag"
+ "git+https://github.com/sonnyp/troll.git#commit=$_trollcommit")
+b2sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ pushd po
+ ln -vf zh_Hans.po zh_CN.po
+ grep zh_CN LINGUAS || echo zh_CN >> LINGUAS
+ cp -vf zh_Hans.po zh_SG.po
+ grep zh_SG LINGUAS || echo zh_SG >> LINGUAS
+
+ rm zh_Hans.po && sed -i '/zh_Hans/d' LINGUAS
+ popd
+
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git -c protocol.file.allow=always submodule update --init --recursive
+}
+
+build() {
+ arch-meson "$_pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}