summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-05-24 18:41:52 +0800
committerdetiam2023-05-24 18:41:52 +0800
commite3c0bbded95cd5c034d83540ed86b961cefc19ab (patch)
treefddb73b07b9a00b16dda7de50ecc36c6dcbafd19
parentc1f9f9eef0455bd54c06cfd75d07bfd7015100ec (diff)
downloadaur-e3c0bbded95cd5c034d83540ed86b961cefc19ab.tar.gz
add note about env XDG_DATA_DIRS
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD2
-rw-r--r--junction.install22
4 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9213f7796b1b..3787cce04df8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = junction-zhfix
pkgrel = 1
epoch = 0
url = https://github.com/sonnyp/Junction
+ install = junction.install
arch = x86_64
license = GPL3
checkdepends = appstream-glib
@@ -14,6 +15,7 @@ pkgbase = junction-zhfix
depends = libadwaita
depends = libportal-gtk4
depends = gjs
+ provides = junction
source = junction-1.6::git+https://github.com/sonnyp/Junction.git#tag=v1.6
source = git+https://github.com/sonnyp/troll.git#commit=fb2d7f26233cea295b23215fd38ecf12a02dbbd0
b2sums = SKIP
diff --git a/.gitignore b/.gitignore
index 4df5cbd2d036..855f83092dc1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.SRCINFO
!.gitignore
!PKGBUILD
+!junction.install
diff --git a/PKGBUILD b/PKGBUILD
index ba9116629bd8..f8444d865950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,8 @@ pkgdesc="Application/browser chooser"
arch=('x86_64')
url="https://github.com/sonnyp/Junction"
license=('GPL3')
+provides=("${_pkgname}")
+install=$_pkgname.install
depends=('libadwaita' 'libportal-gtk4' 'gjs')
makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler')
checkdepends=('appstream-glib')
diff --git a/junction.install b/junction.install
new file mode 100644
index 000000000000..4903b0740d85
--- /dev/null
+++ b/junction.install
@@ -0,0 +1,22 @@
+#!/bin/sh
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} Note:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "add '/usr/share/:/usr/local/share/' to you XDG_DATA_DIRS env, e.g"
+ msg_blue 'echo 'XDG_DATA_DIRS=\"\$XDG_DATA_DIRS:/usr/share/:/usr/local/share/\"' >> /etc/environment'
+}
+
+post_upgrade() {
+ post_install
+}