summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-05-24 19:48:46 +0800
committerdetiam2023-05-24 19:48:46 +0800
commite7798b1b7a764a159a6f559fa2276c93a0147809 (patch)
tree27ea2334be3ef27344c54c5fafe2a10fe008a6c8
parente3c0bbded95cd5c034d83540ed86b961cefc19ab (diff)
downloadaur-e7798b1b7a764a159a6f559fa2276c93a0147809.tar.gz
fix fail to start in none flatpak environment
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD24
-rw-r--r--junction.install22
3 files changed, 12 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3787cce04df8..3f0fd41df3f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,6 @@ pkgbase = junction-zhfix
pkgrel = 1
epoch = 0
url = https://github.com/sonnyp/Junction
- install = junction.install
arch = x86_64
license = GPL3
checkdepends = appstream-glib
@@ -17,8 +16,6 @@ pkgbase = junction-zhfix
depends = gjs
provides = junction
source = junction-1.6::git+https://github.com/sonnyp/Junction.git#tag=v1.6
- source = git+https://github.com/sonnyp/troll.git#commit=fb2d7f26233cea295b23215fd38ecf12a02dbbd0
- b2sums = SKIP
b2sums = SKIP
pkgname = junction-zhfix
diff --git a/PKGBUILD b/PKGBUILD
index f8444d865950..7d0c67d70e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,6 @@ _pkgname=junction
pkgname=junction-zhfix
pkgver=1.6
_tag=v$pkgver
-_trollcommit=fb2d7f26233cea295b23215fd38ecf12a02dbbd0
pkgrel=1
epoch=0
pkgdesc="Application/browser chooser"
@@ -13,18 +12,16 @@ arch=('x86_64')
url="https://github.com/sonnyp/Junction"
license=('GPL3')
provides=("${_pkgname}")
-install=$_pkgname.install
depends=('libadwaita' 'libportal-gtk4' 'gjs')
makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler')
checkdepends=('appstream-glib')
-source=("${_pkgname}-${pkgver}::git+$url.git#tag=$_tag"
- "git+https://github.com/sonnyp/troll.git#commit=$_trollcommit")
-b2sums=('SKIP'
- 'SKIP')
+source=("${_pkgname}-${pkgver}::git+$url.git#tag=$_tag")
+b2sums=('SKIP')
prepare() {
cd "$_pkgname-$pkgver"
+ # fix zh lang
pushd po
ln -vf zh_Hans.po zh_CN.po
grep zh_CN LINGUAS || echo zh_CN >> LINGUAS
@@ -34,9 +31,12 @@ prepare() {
rm zh_Hans.po && sed -i '/zh_Hans/d' LINGUAS
popd
- git submodule init
- git config submodule.src/troll.url "$srcdir/troll"
- git -c protocol.file.allow=always submodule update --init --recursive
+ # fix fail to start in none flatpak environment
+ pushd src
+ sed -i 's|XDG_DATA_DIRS.*e |FLATPAK_ID=fromAUR XDG_DATA_DIRS=${XDG_DATA_DIRS}:/usr/share |' bin.js
+ popd
+
+ git submodule update --init --recursive
}
build() {
@@ -44,9 +44,9 @@ build() {
meson compile -C build
}
-check() {
- meson test -C build --print-errorlogs || :
-}
+#check() {
+# meson test -C build --print-errorlogs || :
+#}
package() {
meson install -C build --destdir "$pkgdir"
diff --git a/junction.install b/junction.install
deleted file mode 100644
index 4903b0740d85..000000000000
--- a/junction.install
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
-note() {
- printf "${blue}==>${yellow} Note:${bold} $1${all_off}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
-post_install() {
- note "add '/usr/share/:/usr/local/share/' to you XDG_DATA_DIRS env, e.g"
- msg_blue 'echo 'XDG_DATA_DIRS=\"\$XDG_DATA_DIRS:/usr/share/:/usr/local/share/\"' >> /etc/environment'
-}
-
-post_upgrade() {
- post_install
-}