summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2017-04-25 22:30:39 +0100
committerFilippo Squillace2017-04-25 22:30:39 +0100
commit2448b817950a8221e52034f770d912dd725e18ae (patch)
tree44312541c6439b6f0504b88234ae5b532c4a091d
parent132665f4017616c9851a3377dd0274235fa5db35 (diff)
downloadaur-2448b817950a8221e52034f770d912dd725e18ae.tar.gz
Chage source for yaourt dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50579ec280a2..cf091b4ac636 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = junest-git
pkgdesc = The Arch Linux based distro that runs upon any Linux distros without root access
pkgver = 6.0.6
- pkgrel = 1
+ pkgrel = 2
url = http://fsquillace.github.io/junest-site/
install = junest.install
arch = any
@@ -12,12 +12,12 @@ pkgbase = junest-git
provides = junest
conflicts = junest
source = junest::git+https://github.com/fsquillace/junest.git#branch=master
- source = https://raw.githubusercontent.com/archlinuxfr/yaourt/master/src/yaourt.sh.in
+ source = https://github.com/archlinuxfr/yaourt/releases/download/1.8.1/yaourt-1.8.1.tar.xz
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-x86_64
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-x86
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-arm
md5sums = SKIP
- md5sums = SKIP
+ md5sums = 0c20b1d7b9c582b896ede30a9d95766b
md5sums = 14080705dd45a6bafa20e909a68072cb
md5sums = b1c08236b56d121e04e9e29b197d0eeb
md5sums = 8218c5f00e77e2e6e04c372ced27c7e7
diff --git a/PKGBUILD b/PKGBUILD
index 88d3b1ace640..ace84235aa86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ fi
pkgname=junest-git
pkgver=6.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="The Arch Linux based distro that runs upon any Linux distros without root access"
arch=('any')
url="http://fsquillace.github.io/junest-site/"
@@ -38,11 +38,14 @@ PROOT_LINK=${MAIN_REPO}/proot
QEMU_LINK=$MAIN_REPO/qemu
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
-source=('junest::git+https://github.com/fsquillace/junest.git#branch=master' "https://raw.githubusercontent.com/archlinuxfr/yaourt/master/src/yaourt.sh.in" "$PROOT_LINK/proot-x86_64" "$PROOT_LINK/proot-x86" "$PROOT_LINK/proot-arm")
+PKGNAME_YAOURT='yaourt'
+PKGVER_YAOURT='1.8.1'
+
+source=('junest::git+https://github.com/fsquillace/junest.git#branch=master' "https://github.com/archlinuxfr/$PKGNAME_YAOURT/releases/download/$PKGVER_YAOURT/$PKGNAME_YAOURT-$PKGVER_YAOURT.tar.xz" "$PROOT_LINK/proot-x86_64" "$PROOT_LINK/proot-x86" "$PROOT_LINK/proot-arm")
source_x86_64=("${QEMU_LINK}/x86_64/qemu-x86_64-static-x86" "${QEMU_LINK}/x86_64/qemu-x86_64-static-arm")
source_i686=("${QEMU_LINK}/x86/qemu-x86-static-x86_64" "${QEMU_LINK}/x86/qemu-x86_64-static-arm")
source_arm=("${QEMU_LINK}/arm/qemu-arm-static-x86_64" "${QEMU_LINK}/arm/qemu-arm-static-x86")
-md5sums=('SKIP' 'SKIP' '14080705dd45a6bafa20e909a68072cb' 'b1c08236b56d121e04e9e29b197d0eeb' '8218c5f00e77e2e6e04c372ced27c7e7')
+md5sums=('SKIP' '0c20b1d7b9c582b896ede30a9d95766b' '14080705dd45a6bafa20e909a68072cb' 'b1c08236b56d121e04e9e29b197d0eeb' '8218c5f00e77e2e6e04c372ced27c7e7')
md5sums_x86_64=('8a706d734f8c790743a8114dda4c344a' '3ced729c95d2514f35d4899e944a4582')
md5sums_x86=('c28d5049193dbce75efa0c8655d71427' 'f75fd15722fcc2914e3de0b0a46eb982')
md5sums_arm=('bd9de1927aae4eb26dc0e5615159a616' 'a7c2b6ca53fa166f0c06ec76cc5edd7d')
@@ -65,6 +68,11 @@ pkgver() {
}
+build() {
+ cd "$srcdir/$PKGNAME_YAOURT-$PKGVER_YAOURT/"
+ make PREFIX=/usr sysconfdir=/etc localstatedir=/var
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
@@ -89,7 +97,7 @@ package() {
echo "Applying patches for yaourt and makepkg"
install -d -m 755 "${pkgdir}/opt/yaourt/bin/"
- install -m 755 yaourt.sh.in ${pkgdir}/opt/yaourt/bin/yaourt
+ install -m 755 "$srcdir/$PKGNAME_YAOURT-$PKGVER_YAOURT/yaourt.sh" ${pkgdir}/opt/yaourt/bin/yaourt
sed -i -e 's@#!/bin/bash@#!/bin/bash\nPATH=/opt/yaourt/bin:$PATH@' ${pkgdir}/opt/yaourt/bin/yaourt
install -m 755 /usr/bin/makepkg ${pkgdir}/opt/yaourt/bin/