summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2016-04-30 20:01:44 +0100
committerFilippo Squillace2016-04-30 20:01:44 +0100
commitab9805fb5607ed1367ddc765e9262559fcfb703f (patch)
tree72e10843191569f0b9ea70e82dddf61eb5442c2c
parent9acb958def1c7022f5851cefc51f69f106907fae (diff)
downloadaur-ab9805fb5607ed1367ddc765e9262559fcfb703f.tar.gz
Use symlink instead of changing the PATH variable
-rw-r--r--PKGBUILD7
-rw-r--r--junest.install3
2 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ae3029eb577..08c8783d6ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://wiki.archlinux.org/index.php/Creating_packages
pkgname=junest-git
-pkgver=r197.cfa5127
+pkgver=r221.3609954
pkgrel=1
pkgdesc="The Arch Linux based distro that runs upon any Linux distros without root access"
arch=('any')
@@ -49,9 +49,8 @@ package() {
mkdir -p "${pkgdir}/opt/"
cp -R "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/${pkgname%-git}"
- mkdir -p "${pkgdir}/etc/profile.d/"
- echo 'export PATH=$PATH:/opt/junest/bin/' > "${pkgdir}/etc/profile.d/junest"
- chmod +x "${pkgdir}/etc/profile.d/junest"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s ../../opt/${pkgname%-git}/bin/${pkgname%-git} ${pkgdir}/usr/bin/${pkgname%-git}
}
# vim:set ts=2 sw=2 et:
diff --git a/junest.install b/junest.install
index d531d67983b0..f3ca896d556c 100644
--- a/junest.install
+++ b/junest.install
@@ -1,6 +1,5 @@
_msg(){
- echo 'Add JuNest binary path in PATH variable:'
- echo ' export PATH=$PATH:/opt/junest/bin'
+ :
}
# arg 1: the new package version