summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2016-06-09 21:10:19 +0100
committerFilippo Squillace2016-06-09 21:10:19 +0100
commitc3ace72e54019879f5df4a6071fc16c4ddde9e5d (patch)
tree8d9999d3c3b9a50aa1c493ddc451a050f160ca1a
parentefeebc8e80be0b7da66f10c587d31d1c4dc7c852 (diff)
downloadaur-c3ace72e54019879f5df4a6071fc16c4ddde9e5d.tar.gz
Include all the proot executables
Since JuNest environment can run on any different architecture, all the proot executables are needed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61e80455a1d7..aa5e11358b91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,15 @@ pkgbase = junest-git
conflicts = junest
source = junest::git+https://github.com/fsquillace/junest.git#branch=master
source = http://static.proot.me//proot-x86_64
+ source = http://static.proot.me//proot-x86
source = https://dl.dropboxusercontent.com/u/42449030/qemu/x86_64/qemu-x86_64-static-x86
+ source = http://static.proot.me//proot-arm
source = https://dl.dropboxusercontent.com/u/42449030/qemu/x86_64/qemu-x86_64-static-arm
md5sums = SKIP
md5sums = 14080705dd45a6bafa20e909a68072cb
+ md5sums = b1c08236b56d121e04e9e29b197d0eeb
md5sums = 8a706d734f8c790743a8114dda4c344a
+ md5sums = 8218c5f00e77e2e6e04c372ced27c7e7
md5sums = 3ced729c95d2514f35d4899e944a4582
pkgname = junest-git
diff --git a/PKGBUILD b/PKGBUILD
index cbd1aa6d8e4c..35a7c1a7b798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,11 +61,11 @@ then
qemu_md5sums["x86"]='a7c2b6ca53fa166f0c06ec76cc5edd7d'
fi
-source+=("$PROOT_LINK/proot-$NORM_ARCH")
-md5sums+=("${proot_md5sums[$NORM_ARCH]}")
-
for archh in ${ARCH_LIST[@]}
do
+ source+=("$PROOT_LINK/proot-$archh")
+ md5sums+=("${proot_md5sums[$archh]}")
+
if [ "$archh" != "$NORM_ARCH" ]
then
source+=("${QEMU_LINK}/qemu-${NORM_ARCH}-static-$archh")
@@ -107,7 +107,10 @@ package() {
echo "Installing proot static binaries"
cd "$srcdir"
install -d -m 755 "${pkgdir}/opt/proot"
- install -m 755 proot-$NORM_ARCH ${pkgdir}/opt/proot/proot-$NORM_ARCH
+ for archh in ${ARCH_LIST[@]}
+ do
+ install -m 755 proot-$archh ${pkgdir}/opt/proot/proot-$archh
+ done
echo "Installing qemu static binaries"
install -d -m 755 "${pkgdir}/opt/qemu"