summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2017-04-24 23:21:00 +0100
committerFilippo Squillace2017-04-24 23:21:00 +0100
commitf4ae97870fa015856e51f748be76f0eaad0b217c (patch)
tree0ae904af019934908a6ebd29f901cb99e05feb8b
parentf7b954ae3b185e206a2be9c229ca6db36821b3fd (diff)
downloadaur-f4ae97870fa015856e51f748be76f0eaad0b217c.tar.gz
Refactor and update to 6.0.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD70
2 files changed, 20 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83bd1b321859..d9382728b72b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = junest-git
pkgdesc = The Arch Linux based distro that runs upon any Linux distros without root access
- pkgver = 5.6.12
- pkgrel = 2
+ pkgver = 6.0.5
+ pkgrel = 1
url = http://fsquillace.github.io/junest-site/
install = junest.install
arch = any
@@ -9,20 +9,17 @@ pkgbase = junest-git
makedepends = git
depends = yaourt
depends = pacman
+ depends = sudo-fake
provides = junest
conflicts = junest
source = junest::git+https://github.com/fsquillace/junest.git#branch=master
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-x86_64
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-x86
- source = https://s3-eu-west-1.amazonaws.com/junest-repo/qemu/x86_64/qemu-x86_64-static-x86
source = https://s3-eu-west-1.amazonaws.com/junest-repo/proot/proot-arm
- source = https://s3-eu-west-1.amazonaws.com/junest-repo/qemu/x86_64/qemu-x86_64-static-arm
md5sums = SKIP
md5sums = 14080705dd45a6bafa20e909a68072cb
md5sums = b1c08236b56d121e04e9e29b197d0eeb
- md5sums = 8a706d734f8c790743a8114dda4c344a
md5sums = 8218c5f00e77e2e6e04c372ced27c7e7
- md5sums = 3ced729c95d2514f35d4899e944a4582
pkgname = junest-git
diff --git a/PKGBUILD b/PKGBUILD
index 4e79a94fe4a1..01e963d5fa4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,6 @@
# https://wiki.archlinux.org/index.php/Creating_packages
# https://wiki.archlinux.org/index.php/Arch_User_Repository#Submitting_packages
-ARCH_LIST=('x86_64' 'x86' 'arm')
HOST_ARCH=$(uname -m)
if [ $HOST_ARCH == "i686" ] || [ $HOST_ARCH == "i386" ]
then
@@ -18,14 +17,14 @@ then
fi
pkgname=junest-git
-pkgver=5.6.12
-pkgrel=2
+pkgver=6.0.5
+pkgrel=1
pkgdesc="The Arch Linux based distro that runs upon any Linux distros without root access"
arch=('any')
url="http://fsquillace.github.io/junest-site/"
license=('GPL')
groups=()
-depends=('yaourt' 'pacman')
+depends=('yaourt' 'pacman' 'sudo-fake')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -33,47 +32,21 @@ replaces=()
backup=()
options=()
install=junest.install
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-source=('junest::git+https://github.com/fsquillace/junest.git#branch=master')
-md5sums=('SKIP')
-noextract=()
MAIN_REPO=https://s3-eu-west-1.amazonaws.com/${pkgname%-git}-repo
PROOT_LINK=${MAIN_REPO}/proot
-QEMU_LINK=$MAIN_REPO/qemu/$NORM_ARCH
-
-declare -A proot_md5sums
-proot_md5sums["x86_64"]='14080705dd45a6bafa20e909a68072cb'
-proot_md5sums["x86"]='b1c08236b56d121e04e9e29b197d0eeb'
-proot_md5sums["arm"]='8218c5f00e77e2e6e04c372ced27c7e7'
-declare -A qemu_md5sums
-if [ "$NORM_ARCH" == "x86_64" ]
-then
- qemu_md5sums["x86"]='8a706d734f8c790743a8114dda4c344a'
- qemu_md5sums["arm"]='3ced729c95d2514f35d4899e944a4582'
-elif [ "$NORM_ARCH" == "x86" ]
-then
- qemu_md5sums["x86_64"]='c28d5049193dbce75efa0c8655d71427'
- qemu_md5sums["arm"]='f75fd15722fcc2914e3de0b0a46eb982'
-elif [ "$NORM_ARCH" == "arm" ]
-then
- qemu_md5sums["x86_64"]='bd9de1927aae4eb26dc0e5615159a616'
- qemu_md5sums["x86"]='a7c2b6ca53fa166f0c06ec76cc5edd7d'
-fi
-
-for archh in ${ARCH_LIST[@]}
-do
- source+=("$PROOT_LINK/proot-$archh")
- md5sums+=("${proot_md5sums[$archh]}")
-
- if [ "$archh" != "$NORM_ARCH" ]
- then
- source+=("${QEMU_LINK}/qemu-${NORM_ARCH}-static-$archh")
- md5sums+=("${qemu_md5sums[$archh]}")
- fi
-done
-
+QEMU_LINK=$MAIN_REPO/qemu
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+source=('junest::git+https://github.com/fsquillace/junest.git#branch=master' "$PROOT_LINK/proot-x86_64" "$PROOT_LINK/proot-x86" "$PROOT_LINK/proot-arm")
+source_x86_64=("${QEMU_LINK}/x86_64/qemu-x86_64-static-x86" "${QEMU_LINK}/x86_64/qemu-x86_64-static-arm")
+source_i686=("${QEMU_LINK}/x86/qemu-x86-static-x86_64" "${QEMU_LINK}/x86/qemu-x86_64-static-arm")
+source_arm=("${QEMU_LINK}/arm/qemu-arm-static-x86_64" "${QEMU_LINK}/arm/qemu-arm-static-x86")
+md5sums=('SKIP' '14080705dd45a6bafa20e909a68072cb' 'b1c08236b56d121e04e9e29b197d0eeb' '8218c5f00e77e2e6e04c372ced27c7e7')
+md5sums_x86_64=('8a706d734f8c790743a8114dda4c344a' '3ced729c95d2514f35d4899e944a4582')
+md5sums_x86=('c28d5049193dbce75efa0c8655d71427' 'f75fd15722fcc2914e3de0b0a46eb982')
+md5sums_arm=('bd9de1927aae4eb26dc0e5615159a616' 'a7c2b6ca53fa166f0c06ec76cc5edd7d')
+noextract=()
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -108,20 +81,11 @@ package() {
echo "Installing proot static binaries"
cd "$srcdir"
install -d -m 755 "${pkgdir}/opt/proot"
- for archh in ${ARCH_LIST[@]}
- do
- install -m 755 proot-$archh ${pkgdir}/opt/proot/proot-$archh
- done
+ install -m 755 proot-* ${pkgdir}/opt/proot
echo "Installing qemu static binaries"
install -d -m 755 "${pkgdir}/opt/qemu"
- for arch in ${ARCH_LIST[@]}
- do
- if [ "$arch" != "$NORM_ARCH" ]
- then
- install -m 755 qemu-${NORM_ARCH}-static-$arch ${pkgdir}/opt/qemu
- fi
- done
+ install -m 755 qemu-* ${pkgdir}/opt/qemu
echo "Applying patches for yaourt and makepkg"
install -d -m 755 "${pkgdir}/opt/yaourt/bin/"