summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Schuett2016-04-08 20:30:46 -0400
committerJonathan Schuett2016-04-08 20:30:46 -0400
commit27aaa4462cd15575123c491b3bea70c1a565f22e (patch)
tree72f89d7b1b6bfe784e9a89c4b73eb3ca69d16e7d
parent60561b52b95da4bbc4b76401cf2070d3c50bf6fc (diff)
downloadaur-27aaa4462cd15575123c491b3bea70c1a565f22e.tar.gz
Updating PKGBUILD to semi-functional version. Correcting download issues. Application execution still nonfunctional
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b377c2aff926..1fce4e130491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,20 +10,17 @@ url="http://junipersknot.dischan.org/"
license=('custom')
depends=('renpy')
options=(!strip)
-source=("JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.org/store/download.php?fileID=14"
+source=("JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.co/downloads/JunipersKnot_en_1.0_lin.tar.bz2"
dischan_JunipersKnot.desktop
- python2.patch
junipersknot
junipersknot.png)
md5sums=('3318de6e4c5952271961d757bdd5fddf'
'672677a075b4ed04f4a3ca71f6c33808'
- 'd00783636657a37728c48b8ce295cc93'
'6b294591761f99d780a8e4d64848aba2'
- '4c498a2152c46fbe993711eaeb91f48e')
+ 'SKIP')
build() {
cd "$srcdir/Juniper's Knot-linux-x86"
- patch -Np1 -i "$srcdir/python2.patch"
}
package() {
@@ -35,5 +32,8 @@ package() {
install -Dm644 DISCHANLICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/DISCHANLICENSE.txt"
install -Dm644 "$srcdir/junipersknot.png" "$pkgdir/usr/share/pixmaps/junipersknot.png"
install -Dm644 "$srcdir/dischan_JunipersKnot.desktop" "$pkgdir/usr/share/applications/dischan_JunipersKnot.desktop"
- cp -r game/* "$pkgdir/usr/share/$pkgname"
+ mv game "$pkgdir/usr/share/$pkgname"
+ mv lib "$pkgdir/usr/share/$pkgname"
+ mv common "$pkgdir/usr/share/$pkgname"
+ mv renpy "$pkgdir/usr/share/$pkgname"
}