summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahor Foruzesh2022-03-15 09:34:40 +0330
committerMahor Foruzesh2022-03-15 09:34:40 +0330
commit4e6ca6fa4310733b8e6d66ec6ae291e07359efe0 (patch)
treea23ec6264b7d94bf320e583fa4adf2980d24d2de
parent0e77219fd47360b3dee5fcbe0abe02b88df94589 (diff)
downloadaur-4e6ca6fa4310733b8e6d66ec6ae291e07359efe0.tar.gz
Make it a split package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD61
2 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dff5808abd4..7e942e5631e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = juno-ocean-standard-buttons-theme-git
- pkgdesc = GTK themes inspired by epic vscode themes
- pkgver = r148.0ed1329
+ pkgdesc = GTK themes inspired by epic VSCode themes
+ pkgver = r149.6d73f68
pkgrel = 1
url = https://github.com/EliverLara/Juno
arch = any
@@ -11,9 +11,10 @@ pkgbase = juno-ocean-standard-buttons-theme-git
optdepends = ttf-roboto: default font for gnome-shell
optdepends = gtk-engine-murrine: GTK2 support
optdepends = gnome-themes-extra: GTK2 support
- provides = juno-ocean-standard-buttons-theme
- conflicts = juno-ocean-standard-buttons-theme
- source = Juno-ocean-standard-buttons::git+https://github.com/EliverLara/Juno.git#branch=ocean-standard-buttons
+ source = juno-ocean-standard-buttons::git+https://github.com/EliverLara/Juno.git#branch=ocean-standard-buttons
sha256sums = SKIP
-pkgname = juno-ocean-standard-buttons-theme-git
+pkgname = juno-ocean-standard-buttons-gtk-theme-git
+ provides = juno-ocean-standard-buttons-gtk-theme
+ conflicts = juno-ocean-standard-buttons-gtk-theme
+ conflicts = juno-ocean-standard-buttons-theme
diff --git a/PKGBUILD b/PKGBUILD
index 41048bb9fefd..8701d77f62e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,34 @@
# Maintainer: Mahor Foruzesh <mahorforuzesh at pm dot me>
-# Original PKGBUILD from https://aur.archlinux.org/packages/juno-theme-git
-# I've only changed pkgname and url
-_pkgname=Juno-ocean-standard-buttons
-pkgname=juno-ocean-standard-buttons-theme-git
-pkgver=r148.0ed1329
+pkgbase=juno-ocean-standard-buttons-theme-git
+__pkgname="${pkgbase%-theme-git}"
+__Pkgname="${__pkgname^}"
+__PkgName="$(echo "$__pkgname" | sed -e "s/\b./\u\0/g")"
+pkgname=(
+ "$__pkgname-gtk-theme-git"
+)
+pkgver=r149.6d73f68
pkgrel=1
-pkgdesc="GTK themes inspired by epic vscode themes"
+pkgdesc="GTK themes inspired by epic VSCode themes"
+arch=("any")
url="https://github.com/EliverLara/Juno"
-license=(GPL3)
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
-arch=(any)
-makedepends=(
- git
- inkscape
- optipng
-)
+license=("GPL3")
+makedepends=("git" "inkscape" "optipng")
optdepends=(
"ttf-roboto: default font for gnome-shell"
"gtk-engine-murrine: GTK2 support"
"gnome-themes-extra: GTK2 support"
)
-source=("${_pkgname}::git+${url}.git#branch=${_pkgname#*-}")
-sha256sums=(SKIP)
+source=("$__pkgname::git+$url.git#branch=${__pkgname#juno-}")
+sha256sums=("SKIP")
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$__pkgname"
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$__pkgname"
export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
@@ -40,16 +37,16 @@ build() {
msg2 "- THEME_FONT_FACE (default font family is Roboto)"
msg2 "- THEME_FONT_SIZE (default font point size is 10)"
msg2 ""
- msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
- msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+ msg2 "Setting gnome-shell font face to $THEME_FONT_FACE"
+ msg2 "Setting gnome-shell font size to $THEME_FONT_SIZE"
- if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
- sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
- "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ if [ "$THEME_FONT_FACE" != "Roboto" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: $THEME_FONT_FACE, \1;/" \
+ "$srcdir/$__pkgname/gnome-shell/gnome-shell.css"
fi
- if [ "${THEME_FONT_SIZE}" != "10" ]; then
+ if [ "$THEME_FONT_SIZE" != "10" ]; then
sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
- "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ "$srcdir/$__pkgname/gnome-shell/gnome-shell.css"
fi
msg2 "Rendering assets, please wait"
@@ -72,8 +69,12 @@ build() {
msg2 "Done!"
}
-package() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}"
- cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+package_juno-ocean-standard-buttons-gtk-theme-git() {
+ provides=("${pkgname[0]%-git}")
+ conflicts=("${pkgname[0]%-git}" "${pkgbase%-git}")
+
+ mkdir -p "$pkgdir/usr/share/themes"
+ cp -a "$srcdir/$__pkgname" "$pkgdir/usr/share/themes/$__Pkgname"
+ cd "$pkgdir/usr/share/themes/$__Pkgname"
+ rm -r ".git"* "Art/" "kde/" "src/" *".json" "Gulpfile.js"
}