summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Holme2020-10-09 11:22:02 +0200
committerChristian Holme2020-10-09 11:26:52 +0200
commit73771fb14f953bf9ee5f9460bff48eab736fd90a (patch)
tree3d54b124e42a199c29b1dba6c15e66613d592797
parent55136c973d2e64a17426651b38717c7c0dd523b9 (diff)
downloadaur-73771fb14f953bf9ee5f9460bff48eab736fd90a.tar.gz
update to 0.7.2, fetch files from pip
Additionally, the separate .install is no longer required
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--jupyter-bash_kernel.install3
3 files changed, 16 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07e9570c0936..a21aadbc09c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = jupyter-bash_kernel
pkgdesc = A Jupyter kernel for bash
- pkgver = 0.4.1
- pkgrel = 2
+ pkgver = 0.7.2
+ pkgrel = 1
url = https://github.com/takluyver/bash_kernel
- install = jupyter-bash_kernel.install
arch = any
license = BSD
- makedepends = python-pip
+ makedepends = python-setuptools
depends = jupyter
depends = jupyter-notebook
depends = bash
- noextract = bash_kernel-0.4.1-py2.py3-none-any.whl
- noextract = LICENSE
- source = https://github.com/takluyver/bash_kernel/releases/download/0.4.1/bash_kernel-0.4.1-py2.py3-none-any.whl
- source = https://github.com/takluyver/bash_kernel/raw/master/LICENSE
- sha256sums = 8e6b3a05d8809644d4d78ed8601dce5344dc3fafa099fe467b199f43a86695fd
- sha256sums = 5b99decdbcae441e047c670b54d017787fb739e22fb1b91d2fc3ef3bafc55ceb
+ depends = python-pexpect
+ source = https://files.pythonhosted.org/packages/source/b/bash_kernel/bash_kernel-0.7.2.tar.gz
+ sha256sums = a08c84eddd8179de5234105821fd5cc210015671a0bd3cd0bc4f631c475e1670
pkgname = jupyter-bash_kernel
diff --git a/PKGBUILD b/PKGBUILD
index 720472d69477..5d25c7df90d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,21 @@
_name=bash_kernel
pkgname=jupyter-${_name}
-pkgver=0.4.1
-pkgrel=2
+pkgver=0.7.2
+pkgrel=1
pkgdesc="A Jupyter kernel for bash"
arch=('any')
url="https://github.com/takluyver/bash_kernel"
license=('BSD')
-depends=('jupyter' 'jupyter-notebook' 'bash')
-makedepends=('python-pip')
-#source=("https://github.com/takluyver/bash_kernel/archive/${pkgver}.tar.gz"
-# "https://github.com/takluyver/bash_kernel/releases/download/${pkgver}/bash_kernel-${pkgver}-py2.py3-none-any.whl")
-source=("https://github.com/takluyver/bash_kernel/releases/download/${pkgver}/bash_kernel-${pkgver}-py2.py3-none-any.whl"
- "https://github.com/takluyver/bash_kernel/raw/master/LICENSE")
-install=${pkgname}.install
-noextract=("bash_kernel-${pkgver}-py2.py3-none-any.whl"
- "LICENSE")
-sha256sums=('8e6b3a05d8809644d4d78ed8601dce5344dc3fafa099fe467b199f43a86695fd'
- '5b99decdbcae441e047c670b54d017787fb739e22fb1b91d2fc3ef3bafc55ceb')
+depends=('jupyter' 'jupyter-notebook' 'bash' 'python-pexpect')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a08c84eddd8179de5234105821fd5cc210015671a0bd3cd0bc4f631c475e1670')
+
package() {
- cd "$srcdir"
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ cd "$srcdir"/${_name}-${pkgver}
+ echo $(pwd)
+ python setup.py install --root="$pkgdir"/ --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/jupyter-bash_kernel.install b/jupyter-bash_kernel.install
deleted file mode 100644
index b4349af8584b..000000000000
--- a/jupyter-bash_kernel.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- python -m bash_kernel.install
-}