summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Holme2020-05-06 14:40:37 +0200
committerChristian Holme2020-05-06 14:40:37 +0200
commite585222397e8b1262f05069ebfaa86dbf5283aa0 (patch)
treeacfa7d6a4066a0b4500cff938f2ec035aadc9328
downloadaur-e585222397e8b1262f05069ebfaa86dbf5283aa0.tar.gz
Inital build, not sure if install works correctly
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
-rw-r--r--jupyter-bash_kernel.install3
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40ae503bfa90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = jupyter-bash_kernel
+ pkgdesc = A Jupyter kernel for bash
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/takluyver/bash_kernel
+ arch = any
+ license = BSD
+ makedepends = python-pip
+ depends = jupyter
+ depends = jupyter-notebook
+ depends = bash
+ noextract = bash_kernel-0.4.1-py2.py3-none-any.whl
+ noextract = LICENSE
+ source = https://github.com/takluyver/bash_kernel/releases/download/0.4.1/bash_kernel-0.4.1-py2.py3-none-any.whl
+ source = https://github.com/takluyver/bash_kernel/raw/master/LICENSE
+ source = jupyter-bash_kernel.install
+ sha256sums = 8e6b3a05d8809644d4d78ed8601dce5344dc3fafa099fe467b199f43a86695fd
+ sha256sums = 5b99decdbcae441e047c670b54d017787fb739e22fb1b91d2fc3ef3bafc55ceb
+ sha256sums = b06d37e6014996d45c95819ae554eebcee3d63c2892025582fdbc2d6416f151a
+
+pkgname = jupyter-bash_kernel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..014b4c4ababe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christian Holme <hcmh (at) kolabnow (dot) com>
+
+_name=bash_kernel
+pkgname=jupyter-${_name}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A Jupyter kernel for bash"
+arch=('any')
+url="https://github.com/takluyver/bash_kernel"
+license=('BSD')
+depends=('jupyter' 'jupyter-notebook' 'bash')
+makedepends=('python-pip')
+#source=("https://github.com/takluyver/bash_kernel/archive/${pkgver}.tar.gz"
+# "https://github.com/takluyver/bash_kernel/releases/download/${pkgver}/bash_kernel-${pkgver}-py2.py3-none-any.whl")
+source=("https://github.com/takluyver/bash_kernel/releases/download/${pkgver}/bash_kernel-${pkgver}-py2.py3-none-any.whl"
+ "https://github.com/takluyver/bash_kernel/raw/master/LICENSE"
+ ${pkgname}.install)
+noextract=("bash_kernel-${pkgver}-py2.py3-none-any.whl"
+ "LICENSE")
+sha256sums=('8e6b3a05d8809644d4d78ed8601dce5344dc3fafa099fe467b199f43a86695fd'
+ '5b99decdbcae441e047c670b54d017787fb739e22fb1b91d2fc3ef3bafc55ceb'
+ 'b06d37e6014996d45c95819ae554eebcee3d63c2892025582fdbc2d6416f151a')
+
+package() {
+ cd "$srcdir"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/jupyter-bash_kernel.install b/jupyter-bash_kernel.install
new file mode 100644
index 000000000000..b4349af8584b
--- /dev/null
+++ b/jupyter-bash_kernel.install
@@ -0,0 +1,3 @@
+post_install() {
+ python -m bash_kernel.install
+}