summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2020-06-15 19:07:08 +0200
committerHenry-Joseph Audéoud2020-06-15 19:07:08 +0200
commit510491e4428f4bf2136ecce126dcbec14592aca2 (patch)
treebf784707477af55482e0f9ebaf9d98cfaaf6947c
downloadaur-510491e4428f4bf2136ecce126dcbec14592aca2.tar.gz
Initial upload: jupyter-nbextension-hide-code 0.5.5-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fb4552998b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jupyter-nbextension-hide-code
+ pkgdesc = Code, prompt and output hiding for Jupyter/IPython notebooks.
+ pkgver = 0.5.5
+ pkgrel = 1
+ url = https://github.com/kirbs-/hide_code
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = jupyter-notebook
+ depends = python-pdfkit
+ conflicts = python-rise
+ source = https://files.pythonhosted.org/packages/source/h/hide_code/hide_code-0.5.5.tar.gz
+ sha256sums = 3517d38277c28314727bf16c6cee3467e4fb5026e08e8201d036c031f537f70b
+
+pkgname = jupyter-nbextension-hide-code
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0df2a8429fef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Henry-Joseph Audéoud <h.audeoud@gmail.com>
+
+pkgname=jupyter-nbextension-hide-code
+_name=hide_code
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="Code, prompt and output hiding for Jupyter/IPython notebooks."
+arch=(any)
+url="https://github.com/kirbs-/hide_code"
+license=('MIT')
+conflicts=('python-rise')
+depends=('python' 'jupyter-notebook' 'python-pdfkit')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3517d38277c28314727bf16c6cee3467e4fb5026e08e8201d036c031f537f70b')
+
+package() {
+ cd "$srcdir/hide_code-$pkgver" || return
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ (
+ local _python3="$(readlink /usr/bin/python3)"
+ local _site_packages="$pkgdir/usr/lib/$_python3/site-packages"
+ export PYTHONPATH="$_site_packages:$PYTHONPATH"
+ export JUPYTER_PATH="$pkgdir/usr/"
+ jupyter-nbextension install --py --prefix="$pkgdir/usr/" "${_name}"
+# jupyter-nbextension enable --py --prefix="$pkgdir/usr/" "${_name}"
+# jupyter-serverextension enable --py --prefix="$pkgdir/usr/" "${_name}"
+ )
+}