summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-08-13 15:57:35 +0100
committergetzze2018-08-13 15:57:35 +0100
commitc762eca1ed626e9716d7df2d72fc2aaf00e0facd (patch)
tree25406186a7eee0b8f556f27651aee4c5c05488b4
parent94a6eb008d42f1299a7b78f2e9011bdfbb4ed161 (diff)
downloadaur-c762eca1ed626e9716d7df2d72fc2aaf00e0facd.tar.gz
5.3.0-2 Change pythonpath
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45bd458cf982..2f951ba33d23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jupyter-nbextension-rise
pkgdesc = Live Reveal.js Jupyter/IPython Slideshow Extension
pkgver = 5.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/damianavila/RISE
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 4373c89ff12b..553685a881da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=jupyter-nbextension-rise
_name=rise
pkgver=5.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Live Reveal.js Jupyter/IPython Slideshow Extension"
arch=(any)
url="https://github.com/damianavila/RISE"
@@ -17,14 +17,21 @@ sha256sums=('b34cc01ff85e47f386456ac4cb0659dcb2fb482c6db05feb5218d43580fea519')
package() {
cd "$srcdir/rise-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Copy the files in static/, including reveal.js/*
# this is incorrectly implemented in setup.py, so several files are missing
- jupyter-nbextension install rise --py --prefix="$pkgdir/usr/"
+ local _python3="$(readlink /usr/bin/python3)"
+ local _site_packages="$pkgdir/usr/lib/$_python3/site-packages"
+
+ env PYTHONPATH="$_site_packages:$PYTHONPATH" \
+ JUPYTER_PATH="$pkgdir/usr/"\
+ JUPYTER_CONFIG_DIR="/etc/jupyter" \
+ jupyter-nbextension install rise --py --prefix="$pkgdir/usr/"
# No need to call `jupyter nbextension install rise`, it is handled in setup.py
# however, change the path from /usr/etc to /etc
mv "$pkgdir"{/usr/etc,/etc}
- install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}