summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrenyuneyun2016-11-17 16:47:43 +0000
committerrenyuneyun2016-11-17 16:47:43 +0000
commit6dbf4223f3e9f3ace244e59f7884ba3ef2705348 (patch)
treeec743ddd1d571395c818f3a0f25df853c06fca2d
parentce80a2098dda4d45550cfba385fa226aa54fe11a (diff)
downloadaur-6dbf4223f3e9f3ace244e59f7884ba3ef2705348.tar.gz
update to 0.16.1
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8fca602c14e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.whl
diff --git a/PKGBUILD b/PKGBUILD
index e71697760e6b..c9206a55e425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: renyuneyun <renyuneyun@gmail.com>
_name=octave_kernel
pkgname=jupyter-${_name}
-pkgver=0.7.1
+pkgver=0.16.1
pkgrel=1
pkgdesc="A Jupyter kernel for Octave"
arch=('any')
@@ -12,15 +12,14 @@ depends=(
'octave'
'python-oct2py'
)
-makedepends=('python-setuptools')
+makedepends=('python-pip')
options=()
-source=("https://github.com/Calysto/octave_kernel/archive/v$pkgver.tar.gz")
-md5sums=('f78644bd8a9f45ad293b1c27a855222d')
+source=("https://pypi.python.org/packages/67/e1/de6980e51757a197a36b9dc82ed10636aaa32e12272517a30596b21ac5a8/${_name}-${pkgver}-py2.py3-none-any.whl")
+md5sums=('49032ec96b36cb54b8693933e989a2c8')
package() {
- cd "$srcdir/${_name}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
}
# vim:set ts=2 sw=2 et: