summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2019-06-27 22:01:08 +0200
committerIyán Méndez Veiga2019-06-27 22:01:08 +0200
commitdc0345357e4a82718904074e2b552301cb3397f8 (patch)
tree523f2ba4e537939754b54226a8ffe65e14e92378
parentb6f92b014b2156435c5a6123e1b17cd4656f1678 (diff)
downloadaur-dc0345357e4a82718904074e2b552301cb3397f8.tar.gz
Change source to Github repo & distutils instead of pip
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1486b464b6b7..8aee56960044 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyter-octave_kernel
pkgdesc = A Jupyter kernel for Octave
- pkgver = 0.31.0
+ pkgver = 0.31.1
pkgrel = 1
url = https://github.com/Calysto/octave_kernel
arch = any
@@ -12,8 +12,8 @@ pkgbase = jupyter-octave_kernel
depends = octave
optdepends = gnuplot: for making plots
optdepends = jupyterlab: JupyterLab computational environment
- source = https://files.pythonhosted.org/packages/py3/o/octave_kernel/octave_kernel-0.31.0-py3-none-any.whl
- sha256sums = 3bec024eed29105af73f6110bb12c8aa6146415743606c91f1b91547a35f4b7c
+ source = https://github.com/Calysto/octave_kernel/archive/v0.31.1.tar.gz
+ sha256sums = b1aa363d3d3858da9c6c7813123de5ce5a9a78aedb4ce872169bb48eb7aedb1d
pkgname = jupyter-octave_kernel
diff --git a/PKGBUILD b/PKGBUILD
index a440a900500e..65b28843c2ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+# Contributor: Julian Mehne <julian (dot) mehne (at) posteo (dot) de>
# Contributor: renyuneyun <renyuneyun (at) gmail (dot) com>
_name=octave_kernel
pkgname=jupyter-${_name}
-pkgver=0.31.0
+pkgver=0.31.1
pkgrel=1
pkgdesc="A Jupyter kernel for Octave"
arch=('any')
@@ -12,10 +13,16 @@ license=('BSD')
depends=('jupyter' 'jupyter-metakernel' 'jupyter-notebook' 'octave')
makedepends=('python-pip')
optdepends=('gnuplot: for making plots' 'jupyterlab: JupyterLab computational environment')
-source=("https://files.pythonhosted.org/packages/py3/${_name::1}/${_name}/${_name/-/_}-${pkgver}-py3-none-any.whl")
-sha256sums=('3bec024eed29105af73f6110bb12c8aa6146415743606c91f1b91547a35f4b7c')
+source=("https://github.com/Calysto/octave_kernel/archive/v${pkgver}.tar.gz")
+sha256sums=('b1aa363d3d3858da9c6c7813123de5ce5a9a78aedb4ce872169bb48eb7aedb1d')
+build() {
+ cd "$srcdir"/$_name-${pkgver}
+ python setup.py build
+}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ cd "$srcdir"/$_name-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file