summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-11-25 21:32:27 +0100
committerPhilipp A2017-11-25 21:32:27 +0100
commit3a373d2f0428d1bea438e0b7d54dc381fb68c17d (patch)
tree2680eb91cd50889215b10763db044e78e02e93e8
parent4bd32ab932a3dd5b25edfd8ff310f9c2789bfbc7 (diff)
downloadaur-3a373d2f0428d1bea438e0b7d54dc381fb68c17d.tar.gz
v0.3.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
-rw-r--r--jupyter_contrib_nbextensions.install19
3 files changed, 41 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a310a4266e3f..ab6f89538073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Nov 25 20:32:13 UTC 2017
pkgbase = jupyter_contrib_nbextensions
pkgdesc = A collection of Jupyter nbextensions
- pkgver = 0.2.6
- pkgrel = 2
+ pkgver = 0.3.3
+ pkgrel = 1
url = https://github.com/ipython-contrib/jupyter_contrib_nbextensions
+ install = jupyter_contrib_nbextensions.install
arch = any
license = BSD
makedepends = python-pip
makedepends = mariadb
+ makedepends = jq
depends = python
+ depends = python-lxml
depends = jupyter
depends = jupyter-notebook
depends = jupyter-nbconvert
@@ -21,9 +26,11 @@ pkgbase = jupyter_contrib_nbextensions
conflicts = python-jupyter-nbextensions
replaces = jupyter-nbextensions-git
replaces = jupyter-nbextensions
- noextract = jupyter_contrib_nbextensions-0.2.6-py2.py3-none-any.whl
- source = jupyter_contrib_nbextensions-0.2.6-py2.py3-none-any.whl::https://files.pythonhosted.org/packages/py2.py3/j/jupyter_contrib_nbextensions/jupyter_contrib_nbextensions-0.2.6-py2.py3-none-any.whl
- md5sums = e67bdc5116cd4f0d1e6a1dfc68776f39
+ noextract = jupyter_contrib_nbextensions-0.3.3-py2.py3-none-any.whl
+ source = jupyter_contrib_nbextensions-0.3.3-py2.py3-none-any.whl::https://files.pythonhosted.org/packages/py2.py3/j/jupyter_contrib_nbextensions/jupyter_contrib_nbextensions-0.3.3-py2.py3-none-any.whl
+ source = jupyter_contrib_nbextensions.install
+ md5sums = 61f0e563c8818127aa5c1162ff0252fd
+ md5sums = 4f2c350b8d9881d3af41d04b2cabcc4d
pkgname = jupyter_contrib_nbextensions
diff --git a/PKGBUILD b/PKGBUILD
index 3b738e34e7a1..cefe6999db4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=jupyter_contrib_nbextensions
-pkgver=0.2.6
-pkgrel=2
+pkgver=0.3.3
+pkgrel=1
pkgdesc='A collection of Jupyter nbextensions'
arch=(any)
url="https://github.com/ipython-contrib/$pkgname"
license=(BSD)
replaces=(jupyter-nbextensions-git jupyter-nbextensions)
conflicts=(jupyter-nbextensions python-jupyter-nbextensions)
-depends=(python jupyter jupyter-notebook jupyter-nbconvert jupyter_contrib_core 'jupyter_nbextensions_configurator>=0.2.4' 'jupyter_highlight_selected_word>=0.0.10' 'jupyter_latex_envs>=1.3.8' python-yaml python-psutil)
-makedepends=(python-pip mariadb)
+depends=(python python-lxml jupyter jupyter-notebook jupyter-nbconvert jupyter_contrib_core 'jupyter_nbextensions_configurator>=0.2.4' 'jupyter_highlight_selected_word>=0.0.10' 'jupyter_latex_envs>=1.3.8' python-yaml python-psutil)
+makedepends=(python-pip mariadb jq)
_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
-source=("$_wheel::https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel")
-md5sums=('e67bdc5116cd4f0d1e6a1dfc68776f39')
+source=("$_wheel::https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel" "$pkgname.install")
+md5sums=('61f0e563c8818127aa5c1162ff0252fd'
+ '4f2c350b8d9881d3af41d04b2cabcc4d')
noextract=("$_wheel")
+install="$pkgname.install"
package() {
local _python3="$(readlink /usr/bin/python3)"
@@ -35,4 +37,6 @@ package() {
for file in $(grep -Frl "$pkgdir" "$pkgdir/etc"); do
replace "$pkgdir/" '' -- $file
done
+
+ rm "$pkgdir/etc/jupyter/jupyter_notebook_config.json"
}
diff --git a/jupyter_contrib_nbextensions.install b/jupyter_contrib_nbextensions.install
new file mode 100644
index 000000000000..d708eb8bbd56
--- /dev/null
+++ b/jupyter_contrib_nbextensions.install
@@ -0,0 +1,19 @@
+fpath='/etc/jupyter/jupyter_notebook_config.json'
+jpath='.NotebookApp.nbserver_extensions.jupyter_nbextensions_configurator'
+
+if [[ -f "$fpath" ]]; then
+ content=$(cat "$fpath")
+else
+ content='{}'
+fi
+
+post_install() {
+ echo "$content" | jq "$jpath = true" >"$fpath"
+}
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ echo "$content" | jq "del($jpath)" >"$fpath"
+}