summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaziar Saleh Ziabari2022-04-20 23:42:41 -0600
committerMaziar Saleh Ziabari2022-04-20 23:42:41 -0600
commit567749224225a7ce574e629a38b4ddbd5955b916 (patch)
tree9906dc4806d3a1f414eb7389adb176f6e8857050
parent174c66aaec9e58f00f4be80359256e3b055fd8c5 (diff)
downloadaur-567749224225a7ce574e629a38b4ddbd5955b916.tar.gz
replace unzip with bsdtar
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 9731419a6e92..84c34fe8b39a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/src/
/*.pkg.tar.xz
/*.whl
+/*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 0273ee0ecf20..fd5150c87fef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,14 @@ depends=(python jupyter-notebook)
_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
source=("$_wheel::https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel")
sha256sums=('9545dfa9cb057eebe3a5795604dcd3a5294ea18637e553f61a0b67c1b5903c58')
+
noextract=("$_wheel")
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
- unzip "$_wheel" -d "$site"
+ local curpath="$(pwd)"
+ cd "$site"
+ bsdtar xvf "$curpath/$_wheel"
+ cd "$curpath"
}