summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-03-04 11:15:20 +0100
committerPhilipp A2020-03-04 11:15:20 +0100
commit7a836adf1487276c72c16bd8f4d1e116b1b4441a (patch)
tree510614e1f1b867a58f5c815a4d1f5f54171815a6
parent3f0180e91a8d2b0a83482875eeaabdf272fcf432 (diff)
downloadaur-7a836adf1487276c72c16bd8f4d1e116b1b4441a.tar.gz
don’t use pip
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3a46d04371..56ea26d15722 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = jupyter_highlight_selected_word
pkgdesc = Jupyter notebook extension that enables highlighting every instance of the current word in the notebook
pkgver = 0.2.0
- pkgrel = 1
- url = https://github.com/ipython-contrib/
+ pkgrel = 2
+ url = https://github.com/jcb91/jupyter_highlight_selected_word
arch = any
license = BSD
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 9cbfa8768137..f2bbc798f443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Phil A. <flying-sheep@web.de>
pkgname=jupyter_highlight_selected_word
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Jupyter notebook extension that enables highlighting every instance of the current word in the notebook'
arch=(any)
-url=https://github.com/ipython-contrib/$_gitname
+url="https://github.com/jcb91/$pkgname"
license=(BSD)
-makedepends=()
depends=(python jupyter jupyter-notebook)
_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
source=("$_wheel::https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel")
@@ -14,5 +13,7 @@ sha256sums=('9545dfa9cb057eebe3a5795604dcd3a5294ea18637e553f61a0b67c1b5903c58')
noextract=("$_wheel")
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}