summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-03-06 15:13:48 +0100
committerPhilipp A2017-03-06 15:13:48 +0100
commit8e11bb9f3c4c6fdd118d897889a51d19db92ca6f (patch)
tree67e5f2989b1c0b87b4b141088f7446179b3b49c2
downloadaur-8e11bb9f3c4c6fdd118d897889a51d19db92ca6f.tar.gz
v1.3.5.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5fce5ede1c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jupyter_latex_envs
+ pkgdesc = Jupyter notebook extension which supports (some) LaTeX environments within markdown cells
+ pkgver = 1.3.5.7
+ pkgrel = 1
+ url = https://github.com/ipython-contrib/
+ arch = any
+ license = BSD
+ depends = python
+ depends = jupyter
+ depends = jupyter-notebook
+ source = https://files.pythonhosted.org/packages/source/j/jupyter_latex_envs/jupyter_latex_envs-1.3.5.7.tar.gz
+ md5sums = ef0135735ac3bfc7c487c8e1a8b56597
+
+pkgname = jupyter_latex_envs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f154a08c6a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+pkgname=jupyter_latex_envs
+pkgver=1.3.5.7
+pkgrel=1
+pkgdesc='Jupyter notebook extension which supports (some) LaTeX environments within markdown cells'
+arch=(any)
+url=https://github.com/ipython-contrib/$_gitname
+license=(BSD)
+makedepends=()
+depends=(python jupyter jupyter-notebook)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('ef0135735ac3bfc7c487c8e1a8b56597')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 || return 1
+}