summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2023-06-10 22:04:48 +0200
committerBlair Bonnett2023-06-10 22:04:48 +0200
commit24dbe67c942b1a3acf560b8b54c32701b7de32e9 (patch)
tree9033b304e3f64cd98acc52069ca4e5405bb865f1
parentbbdef7d6f294dacad88c32c921da1d8815ab0c50 (diff)
downloadaur-24dbe67c942b1a3acf560b8b54c32701b7de32e9.tar.gz
Update to 4.0.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--jupyterhub.service6
-rw-r--r--tests_use_random_ports.patch2
4 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d1a3a0d3c9..311542a92f26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyterhub
pkgdesc = Multi-user server for Jupyter notebooks
- pkgver = 3.0.0
+ pkgver = 4.0.1
pkgrel = 1
url = https://jupyter.org/hub
install = jupyterhub.install
@@ -11,6 +11,7 @@ pkgbase = jupyterhub
checkdepends = python-pytest
checkdepends = python-pytest-asyncio
checkdepends = python-requests-mock
+ checkdepends = python-playwright
makedepends = npm
makedepends = python-build
makedepends = python-installer
@@ -38,11 +39,11 @@ pkgbase = jupyterhub
optdepends = python-pycurl: improved HTTP performance
optdepends = python-statsd: send metrics to a StatsD server
backup = etc/jupyterhub/jupyterhub_config.py
- source = jupyterhub-3.0.0.tar.gz::https://github.com/jupyterhub/jupyterhub/archive/3.0.0.tar.gz
+ source = jupyterhub-4.0.1.tar.gz::https://github.com/jupyterhub/jupyterhub/archive/4.0.1.tar.gz
source = jupyterhub.service
source = tests_use_random_ports.patch
- sha256sums = 3ddcd96ae291b24571f9aa42e6316410379d46068482e35bad7691cb336dcc72
+ sha256sums = 39a396119e8f62d011fc2e091898097fb9279e4539474eb0c6a5deeb76ae5000
sha256sums = adb4c09c668c35605d9cddc4a4171dd64ed6e74ab82da97f19b3437d26b052b9
- sha256sums = 05a86fad6eada56e1128f7ebaf038524d6182b6453427bbc27a58331992b7308
+ sha256sums = 031b504b08c67dfbd6047a31a3cf5555a06cfb04b8c0a637206d548e48845ab1
pkgname = jupyterhub
diff --git a/PKGBUILD b/PKGBUILD
index c4b77ef516d9..89a80c15e6d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Mark Lee <mark at markelee dot com>
pkgname=jupyterhub
-pkgver=3.0.0
+pkgver=4.0.1
pkgrel=1
pkgdesc="Multi-user server for Jupyter notebooks"
url="https://jupyter.org/hub"
@@ -22,7 +22,7 @@ makedepends=(
)
checkdepends=(
'jupyter-notebook' 'python-beautifulsoup4' 'python-pytest'
- 'python-pytest-asyncio' 'python-requests-mock'
+ 'python-pytest-asyncio' 'python-requests-mock' 'python-playwright'
)
optdepends=(
'jupyter-notebook: standard notebook server'
@@ -40,9 +40,9 @@ source=(
'tests_use_random_ports.patch'
)
sha256sums=(
- '3ddcd96ae291b24571f9aa42e6316410379d46068482e35bad7691cb336dcc72'
- 'adb4c09c668c35605d9cddc4a4171dd64ed6e74ab82da97f19b3437d26b052b9'
- '05a86fad6eada56e1128f7ebaf038524d6182b6453427bbc27a58331992b7308'
+ '39a396119e8f62d011fc2e091898097fb9279e4539474eb0c6a5deeb76ae5000'
+ 'f851dac9e098afa1dfcf30169b23414e7384559984eb7090aaf3c4f9c1c84997'
+ '031b504b08c67dfbd6047a31a3cf5555a06cfb04b8c0a637206d548e48845ab1'
)
prepare() {
@@ -71,6 +71,7 @@ check() {
local skip_files=(
# DB upgrade tests always seem to fail (virtual environment appears incorrect).
+ # Assume the upstream CI checks the upgrades work.
'test_db.py'
# Broken by our patch to use random ports for testing. This enables a lot
@@ -110,14 +111,16 @@ check() {
done
testargs+=('-k' "${karg:5}") # Trim the leading ' and '.
- PYTHONPATH="$PWD/build/lib" pytest -v jupyterhub "${testargs[@]}"
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer "dist/jupyterhub-$pkgver"-*.whl
+ test-env/bin/python -m pytest -v jupyterhub "${testargs[@]}"
}
package() {
cd "${srcdir}/jupyterhub-$pkgver"
# Install the package.
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" "dist/jupyterhub-$pkgver"-*.whl
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING.md
# Remove $srcdir references from npm metadata.
diff --git a/jupyterhub.service b/jupyterhub.service
index 34a31173b1db..8de7eb6d9483 100644
--- a/jupyterhub.service
+++ b/jupyterhub.service
@@ -20,7 +20,7 @@ ExecStart=/usr/bin/jupyterhub \
# Apply some service hardening.
# The default LocalProcess spawner needs SETUID and SETGID to run the
-# single-user servers.
+# single-user servers. For other spawners you could probably remove these.
CapabilityBoundingSet=CAP_SETUID CAP_SETGID
LockPersonality=true
NoNewPrivileges=true
@@ -42,5 +42,9 @@ SystemCallArchitectures=native
SystemCallErrorNumber=EPERM
SystemCallFilter=@system-service
+# Some other hardening that could be enabled for specific setups.
+# PrivateUsers=true # Not with LocalSpawner
+# MemoryDenyWriteExecute=true # Not with configurable-http-proxy
+
[Install]
WantedBy=multi-user.target
diff --git a/tests_use_random_ports.patch b/tests_use_random_ports.patch
index b65f493cfee1..aa9f4c0ca228 100644
--- a/tests_use_random_ports.patch
+++ b/tests_use_random_ports.patch
@@ -1,7 +1,7 @@
--- jupyterhub/tests/mocking.py
+++ jupyterhub/tests/mocking.py
-@@ -237,6 +237,8 @@
+@@ -240,6 +240,8 @@
if 'internal_certs_location' in kwargs:
cert_location = kwargs['internal_certs_location']
kwargs['external_certs'] = ssl_setup(cert_location, 'hub-ca')