summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-09-16 12:56:22 +0200
committerBlair Bonnett2022-09-16 12:56:22 +0200
commitbbdef7d6f294dacad88c32c921da1d8815ab0c50 (patch)
tree18e580d2c5aae118eee482aa51834cdab96c1e68
parent8e22bcc9c89b5df1565bb4612233f40eb6a12e48 (diff)
downloadaur-bbdef7d6f294dacad88c32c921da1d8815ab0c50.tar.gz
Update to 3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--jupyterhub.install15
-rw-r--r--tests_use_random_ports.patch6
4 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cde1499ec34b..84d1a3a0d3c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyterhub
pkgdesc = Multi-user server for Jupyter notebooks
- pkgver = 2.3.1
+ pkgver = 3.0.0
pkgrel = 1
url = https://jupyter.org/hub
install = jupyterhub.install
@@ -14,6 +14,7 @@ pkgbase = jupyterhub
makedepends = npm
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
depends = ipython
depends = nodejs-configurable-http-proxy
@@ -35,12 +36,13 @@ pkgbase = jupyterhub
optdepends = jupyter-notebook: standard notebook server
optdepends = jupyterlab: to use the JupyterLab interface
optdepends = python-pycurl: improved HTTP performance
+ optdepends = python-statsd: send metrics to a StatsD server
backup = etc/jupyterhub/jupyterhub_config.py
- source = jupyterhub-2.3.1.tar.gz::https://github.com/jupyterhub/jupyterhub/archive/2.3.1.tar.gz
+ source = jupyterhub-3.0.0.tar.gz::https://github.com/jupyterhub/jupyterhub/archive/3.0.0.tar.gz
source = jupyterhub.service
source = tests_use_random_ports.patch
- sha256sums = dd9605462c1e382b3cc374226ffe9f550cc59643a9de05bbea67630f4a3f6c5a
+ sha256sums = 3ddcd96ae291b24571f9aa42e6316410379d46068482e35bad7691cb336dcc72
sha256sums = adb4c09c668c35605d9cddc4a4171dd64ed6e74ab82da97f19b3437d26b052b9
- sha256sums = acba51024276670aabad3d3f2a1c80d4b573809ca7e7ef6594916329d842417f
+ sha256sums = 05a86fad6eada56e1128f7ebaf038524d6182b6453427bbc27a58331992b7308
pkgname = jupyterhub
diff --git a/PKGBUILD b/PKGBUILD
index 4f6877cfaf64..c4b77ef516d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Mark Lee <mark at markelee dot com>
pkgname=jupyterhub
-pkgver=2.3.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="Multi-user server for Jupyter notebooks"
url="https://jupyter.org/hub"
@@ -18,7 +18,7 @@ depends=(
'python-sqlalchemy' 'python-tornado' 'python-traitlets'
)
makedepends=(
- 'npm' 'python-build' 'python-installer' 'python-wheel'
+ 'npm' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel'
)
checkdepends=(
'jupyter-notebook' 'python-beautifulsoup4' 'python-pytest'
@@ -28,6 +28,7 @@ optdepends=(
'jupyter-notebook: standard notebook server'
'jupyterlab: to use the JupyterLab interface'
'python-pycurl: improved HTTP performance'
+ 'python-statsd: send metrics to a StatsD server'
)
install=jupyterhub.install
backup=(
@@ -39,9 +40,9 @@ source=(
'tests_use_random_ports.patch'
)
sha256sums=(
- 'dd9605462c1e382b3cc374226ffe9f550cc59643a9de05bbea67630f4a3f6c5a'
+ '3ddcd96ae291b24571f9aa42e6316410379d46068482e35bad7691cb336dcc72'
'adb4c09c668c35605d9cddc4a4171dd64ed6e74ab82da97f19b3437d26b052b9'
- 'acba51024276670aabad3d3f2a1c80d4b573809ca7e7ef6594916329d842417f'
+ '05a86fad6eada56e1128f7ebaf038524d6182b6453427bbc27a58331992b7308'
)
prepare() {
@@ -59,7 +60,7 @@ build() {
# installed' headers with 'Included with the jupyterhub package'.
cd build/lib
python -m jupyterhub --generate-config -f "$srcdir/default_config.py" -y True
- _srcdir_esc="${srcdir////\\/}"
+ local _srcdir_esc="${srcdir////\\/}"
sed -i "$srcdir/default_config.py" \
-e "s/${_srcdir_esc}\/jupyterhub-$pkgver/\/usr/" \
-e 's/# Currently installed:/# Included with the jupyterhub package:/'
@@ -68,7 +69,7 @@ build() {
check() {
cd "${srcdir}/jupyterhub-$pkgver"
- skip_files=(
+ local skip_files=(
# DB upgrade tests always seem to fail (virtual environment appears incorrect).
'test_db.py'
@@ -77,7 +78,7 @@ check() {
'test_internal_ssl_connections.py'
)
- skip_tests=(
+ local skip_tests=(
# Needs the package to already be installed.
'test_server_token_role'
@@ -97,13 +98,13 @@ check() {
fi
# Start building pytest args with --ignore options for whole files.
- testargs=()
+ local testargs=()
for filename in "${skip_files[@]}"; do
testargs+=("--ignore=jupyterhub/tests/$filename")
done
# Add a filter expression with all the tests we want to skip.
- karg=""
+ local karg=""
for testname in "${skip_tests[@]}"; do
karg="$karg and not $testname"
done
diff --git a/jupyterhub.install b/jupyterhub.install
index 46d662721368..b244d743075e 100644
--- a/jupyterhub.install
+++ b/jupyterhub.install
@@ -4,9 +4,16 @@ post_upgrade () {
# Upgrading from pre-1.4.0: output message about new systemd service.
if [ $(vercmp "$2" 1.4.0-1) -lt 0 ]; then
echo "From 1.4.0-1 this package provides a systemd service file at"
- echo " /usr/lib/systemd/system/jupyterhub.service"
- echo "If you have a custom service in /etc/systemd/system or a"
- echo "similar location, it will continue to be used instead of the"
- echo "service from this package."
+ echo " /usr/lib/systemd/system/jupyterhub.service"
+ echo "If you have a custom service in /etc/systemd/system or a"
+ echo "similar location, it will continue to be used instead of the"
+ echo "service from this package."
+ fi
+
+ # Warn about database schema changes.
+ if [ $(vercmp "$2" 3.0.0-1) -lt 0 ]; then
+ echo "Version 3.0.0 includes a database schema change. You will"
+ echo "need to upgrade your database before you can run it."
+ echo "See the JupyterHub documentation for details."
fi
}
diff --git a/tests_use_random_ports.patch b/tests_use_random_ports.patch
index 9c3c0aeff6f7..b65f493cfee1 100644
--- a/tests_use_random_ports.patch
+++ b/tests_use_random_ports.patch
@@ -1,7 +1,7 @@
--- jupyterhub/tests/mocking.py
+++ jupyterhub/tests/mocking.py
-@@ -245,6 +245,8 @@
+@@ -237,6 +237,8 @@
if 'internal_certs_location' in kwargs:
cert_location = kwargs['internal_certs_location']
kwargs['external_certs'] = ssl_setup(cert_location, 'hub-ca')
@@ -19,8 +19,8 @@
from ..utils import wait_for_http_server
+from ..utils import random_port
from .mocking import MockHub
- from .test_api import add_user
-@@ -32,9 +33,10 @@
+ from .test_api import add_user, api_request
+@@ -31,9 +32,10 @@
auth_token = 'secret!'
proxy_ip = '127.0.0.1'
- proxy_port = 54321