summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-02-03 13:57:09 +0100
committerPhilipp A2021-02-03 13:57:09 +0100
commit31f211eab991f712286c3903f5423c8399533855 (patch)
tree95c26fb69c85ea5227ad96e73c58861745511d03
downloadaur-31f211eab991f712286c3903f5423c8399533855.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a02cdba1228
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jupyterlab-extension-jupyterlab_git
+ pkgdesc = Git extension for JupyterLab
+ pkgver = 0.30.0b1
+ pkgrel = 1
+ url = https://github.com/jupyterlab/jupyterlab-git
+ arch = any
+ license = BSD
+ depends = jupyterlab
+ depends = jupyter-server
+ depends = python-nbdime
+ depends = python-packaging
+ depends = python-pexpect
+ provides = jupyterlab-extension-git
+ provides = python-jupyterlab-git
+ source = https://files.pythonhosted.org/packages/py3/j/jupyterlab-git/jupyterlab_git-0.30.0b1-py3-none-any.whl
+ sha256sums = d5c2daced422004643a4eab8e3a5676e204e9df32cae54674684965e2e20870f
+
+pkgname = jupyterlab-extension-jupyterlab_git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3cc40a81f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e70689f0bd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+_name=jupyterlab-git
+pkgname=jupyterlab-extension-jupyterlab_git
+pkgver=0.30.0b1
+pkgrel=1
+pkgdesc='Git extension for JupyterLab'
+arch=(any)
+url=https://github.com/jupyterlab/$_name
+license=(BSD)
+depends=(jupyterlab jupyter-server python-nbdime python-packaging python-pexpect)
+provides=(jupyterlab-extension-git python-jupyterlab-git)
+_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('d5c2daced422004643a4eab8e3a5676e204e9df32cae54674684965e2e20870f')
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ install -d "$site"
+ unzip "$_wheel" -d "$site"
+ mv "$site/${_name/-/_}-$pkgver.data/data/"* "$pkgdir/usr/"
+}