summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-04-14 12:05:52 +0200
committerPhilipp A2022-04-14 12:05:52 +0200
commit45e69e8033bd55b76932a385e9200a0c5af963a5 (patch)
tree8e5ddb0dd6d368f7dccd53ca9347c5024f372cb7
parent5f5d9070db1ce335c3ec36d1b87783f00afc3e31 (diff)
downloadaur-45e69e8033bd55b76932a385e9200a0c5af963a5.tar.gz
v0.36.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62755c97c2a8..6ed3220d0f75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyterlab-extension-jupyterlab_git
pkgdesc = Git extension for JupyterLab
- pkgver = 0.34.0
+ pkgver = 0.36.0
pkgrel = 1
url = https://github.com/jupyterlab/jupyterlab-git
arch = any
@@ -9,11 +9,12 @@ pkgbase = jupyterlab-extension-jupyterlab_git
depends = jupyterlab
depends = jupyter-server
depends = python-nbdime
+ depends = jupyter-nbformat
depends = python-packaging
depends = python-pexpect
provides = jupyterlab-extension-git
provides = python-jupyterlab-git
- source = https://files.pythonhosted.org/packages/py3/j/jupyterlab-git/jupyterlab_git-0.34.0-py3-none-any.whl
- sha256sums = 64a39f62d07b624b9e3fb4c2d5a03263812803d052164dadf22bee49ec272065
+ source = https://files.pythonhosted.org/packages/py3/j/jupyterlab-git/jupyterlab_git-0.36.0-py3-none-any.whl
+ sha256sums = 0af436290f2f6c18a52ad3b40631d637b398205623158157faebd02ef6666e2c
pkgname = jupyterlab-extension-jupyterlab_git
diff --git a/.gitignore b/.gitignore
index cb3cc40a81f9..910c2436b01b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.pkg.tar.xz
+/*.pkg.*
/*.whl
diff --git a/PKGBUILD b/PKGBUILD
index 3fb82e1e0378..93eef9db1b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Anthony Wang <ta180m@gmail.com>
_name=jupyterlab-git
pkgname=jupyterlab-extension-jupyterlab_git
-pkgver=0.34.0
+pkgver=0.36.0
pkgrel=1
pkgdesc='Git extension for JupyterLab'
arch=(any)
url=https://github.com/jupyterlab/$_name
license=(BSD)
-depends=(jupyterlab jupyter-server python-nbdime python-packaging python-pexpect)
+depends=(jupyterlab jupyter-server python-nbdime jupyter-nbformat python-packaging python-pexpect)
makedepends=(unzip)
provides=(jupyterlab-extension-git python-jupyterlab-git)
_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
-sha256sums=('64a39f62d07b624b9e3fb4c2d5a03263812803d052164dadf22bee49ec272065')
+sha256sums=('0af436290f2f6c18a52ad3b40631d637b398205623158157faebd02ef6666e2c')
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"