summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192021-02-01 20:45:53 +0800
committerspecter1192021-02-01 20:45:53 +0800
commit188ade16634f6ce2698224411b4da1a9be1885b4 (patch)
tree33cf621b0f9e2aa4fb4490fca6395000d432a199
parentc3c37fd3ea3ac83ee522fa88af19b09d5b3e89bf (diff)
downloadaur-188ade16634f6ce2698224411b4da1a9be1885b4.tar.gz
update to 1.4.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8de811b982c..4699eb97647b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyterlab_code_formatter
pkgdesc = A universal code formatter for JupyterLab.
- pkgver = 1.3.1
+ pkgver = 1.4.3
pkgrel = 1
url = https://pypi.org/project/jupyterlab-code-formatter
arch = any
@@ -8,16 +8,15 @@ pkgbase = jupyterlab_code_formatter
makedepends = python-setuptools
depends = python
depends = jupyterlab
- depends = jupyter-notebook
- depends = python-packaging
+ depends = python-jupyter_packaging
optdepends = autopep8
optdepends = yapf
optdepends = python-isort
optdepends = python-black
- source = https://files.pythonhosted.org/packages/source/j/jupyterlab_code_formatter/jupyterlab_code_formatter-1.3.1.tar.gz
+ source = https://files.pythonhosted.org/packages/source/j/jupyterlab_code_formatter/jupyterlab_code_formatter-1.4.3.tar.gz
source = https://raw.githubusercontent.com/ryantam626/jupyterlab_code_formatter/master/LICENSE
- md5sums = d5cc37551ce4eec52fafdca45230281c
- md5sums = ec87bcae7352e3d6ac5eaefcd89fe8d9
+ md5sums = f0d70901b18bc8dda31bc9057b3f9b89
+ md5sums = SKIP
pkgname = jupyterlab_code_formatter
diff --git a/PKGBUILD b/PKGBUILD
index 4998ba048a26..d4bdd2950b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Ke Liu <spcter119@gmail.com>
pkgname=jupyterlab_code_formatter
-pkgver=1.3.1
+pkgver=1.4.3
pkgrel=1
pkgdesc='A universal code formatter for JupyterLab.'
arch=(any)
url=https://pypi.org/project/jupyterlab-code-formatter
license=(MIT)
-depends=(python jupyterlab jupyter-notebook python-packaging)
+depends=(python jupyterlab python-jupyter_packaging)
makedepends=(python-setuptools)
optdepends=(autopep8 yapf python-isort python-black)
source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz
https://raw.githubusercontent.com/ryantam626/jupyterlab_code_formatter/master/LICENSE)
-md5sums=('d5cc37551ce4eec52fafdca45230281c'
- 'ec87bcae7352e3d6ac5eaefcd89fe8d9')
+md5sums=('f0d70901b18bc8dda31bc9057b3f9b89'
+ 'SKIP')
build() {
cd $srcdir/${pkgname}-${pkgver}