summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Huang2020-06-18 12:40:35 -0400
committerJason Huang2020-06-18 12:44:09 -0400
commitb61a74d49d179dbc6794cb36cc530455bb75cae9 (patch)
treeb0c4e0fc4dd6bbd54c5bd775a03269f88322afab
downloadaur-b61a74d49d179dbc6794cb36cc530455bb75cae9.tar.gz
Create Initial Package
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD37
-rw-r--r--jurism.desktop8
-rw-r--r--jurism.install13
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a48258cf5039
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jurism
+ pkgdesc = Juris-M Standalone. Is a variant of Zotero, with legal and multilingual support.
+ pkgver = 5.0.85m3
+ pkgrel = 1
+ url = https://juris-m.github.io/downloads
+ install = jurism.install
+ arch = x86_64
+ license = GPL3
+ depends = dbus-glib
+ depends = gtk3
+ depends = nss
+ depends = libxt
+ source = jurism.desktop
+ sha256sums = e77753174477bfd22d9b983e9e53954e9579e944c2b62bf32fcbdf17f1b36281
+ source_x86_64 = Jurism-5.0.85m3_linux_x86_64.tar.bz2::https://our.law.nagoya-u.ac.jp/jurism/dl?channel=release&platform=linux-x86_64&version=5.0.85m3
+ sha256sums_x86_64 = 5df76303aecc0daaeddc374e578d6fac68266294b0587df83d2bee2862a5fe63
+
+pkgname = jurism
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..45e558a3c479
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore all files
+*
+
+# Add necessary files
+!.gitignore
+!.SRCINFO
+!jurism.desktop
+!jurism.install
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e642c366c8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jason Huang <jasonhuang20035 at gmail dot com>
+
+# Based on the zotero PKGBUILD
+
+pkgname=jurism
+pkgver=5.0.85m3
+pkgrel=1
+pkgdesc="Juris-M Standalone. Is a variant of Zotero, with legal and multilingual support."
+arch=('x86_64')
+url="https://juris-m.github.io/downloads"
+license=('GPL3')
+depends=('dbus-glib' 'gtk3' 'nss' 'libxt')
+
+sha256sums=('e77753174477bfd22d9b983e9e53954e9579e944c2b62bf32fcbdf17f1b36281')
+sha256sums_x86_64=('5df76303aecc0daaeddc374e578d6fac68266294b0587df83d2bee2862a5fe63')
+
+install='jurism.install'
+
+source=("jurism.desktop")
+source_x86_64=("Jurism-${pkgver}_linux_$CARCH.tar.bz2::https://our.law.nagoya-u.ac.jp/jurism/dl?channel=release&platform=linux-$CARCH&version=${pkgver}")
+
+package() {
+ install -dDm755 "$pkgdir"/usr/{bin,lib/jurism}
+ mv "$srcdir"/Jurism_linux-$CARCH/* "$pkgdir"/usr/lib/jurism
+ ln -s /usr/lib/jurism/jurism "$pkgdir"/usr/bin/jurism
+ install -Dm644 "$srcdir"/jurism.desktop "$pkgdir"/usr/share/applications/jurism.desktop
+ # Copy jurism icons to a standard location
+ install -Dm644 "$pkgdir"/usr/lib/jurism/chrome/icons/default/default16.png "$pkgdir"/usr/share/icons/hicolor/16x16/apps/jurism.png
+ install -Dm644 "$pkgdir"/usr/lib/jurism/chrome/icons/default/default32.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/jurism.png
+ install -Dm644 "$pkgdir"/usr/lib/jurism/chrome/icons/default/default48.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/jurism.png
+ install -Dm644 "$pkgdir"/usr/lib/jurism/chrome/icons/default/default256.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/jurism.png
+ # Disable APP update
+ sed -i '/pref("app.update.enabled", true);/c\pref("app.update.enabled", false);' "$pkgdir"/usr/lib/jurism/defaults/preferences/prefs.js
+ # No need to keep a shell around when launching Juris-M
+ sed -i -r 's/^("\$CALLDIR\/jurism-bin" -app "\$CALLDIR\/application.ini" "\$@")/exec \1/' "$pkgdir"/usr/lib/jurism/jurism
+}
+
diff --git a/jurism.desktop b/jurism.desktop
new file mode 100644
index 000000000000..6e44418c04f4
--- /dev/null
+++ b/jurism.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Juris-M
+GenericName=Juris-M Standalone. Is a variant of Zotero, with legal and multilingual support.
+Icon=jurism
+Exec=/usr/bin/jurism %f
+Categories=Office
+Terminal=false
diff --git a/jurism.install b/jurism.install
new file mode 100644
index 000000000000..565a7caface3
--- /dev/null
+++ b/jurism.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "Maybe you want the context menu icons enabled. This can be done in dconf or using the CLI:"
+ echo "gsettings set org.gnome.desktop.interface menus-have-icons true"
+ echo "DISCLAIMER: Notice that this is a system-wide configuration and it will change appearence in other programs too."
+
+}
+
+post_upgrade() {
+ # Only show information if upgrading from 4.0.6 or older
+ if [ $(vercmp $2 4.0.6-1) -le 0 ]; then
+ post_install
+ fi
+}