summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-08 15:03:11 +0200
committerhaawda2017-10-08 15:03:11 +0200
commitd0d3b9a8aa0b0680536ce689514ed594603a1430 (patch)
tree725f4442c18f006c4ea6e35364c00b58d9a9ce6c
parentb0d7ce484216ad270d79d424136db04307cf036b (diff)
downloadaur-d0d3b9a8aa0b0680536ce689514ed594603a1430.tar.gz
adopt
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acc7920d73d0..d5b4235c3e10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Nov 5 03:14:37 UTC 2016
pkgbase = just-git
pkgdesc = Just a command runner, like make.
- pkgver = 0.2.15.173
+ pkgver = 0.3.1.326
pkgrel = 1
url = https://github.com/casey/just
arch = x86_64
@@ -13,7 +11,7 @@ pkgbase = just-git
makedepends = cargo
provides = just
conflicts = just
- source = just-git::git+https://github.com/casey/just.git
+ source = git+https://github.com/casey/just.git
sha256sums = SKIP
pkgname = just-git
diff --git a/PKGBUILD b/PKGBUILD
index e93edb28a6e7..cbc236ac92bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=just-git
-pkgver=0.2.15.173
+pkgver=0.3.1.326
pkgrel=1
pkgdesc="Just a command runner, like make."
arch=('x86_64' 'i686')
url="https://github.com/casey/just"
license=('WTFPL' 'MIT' 'Apache-2.0')
-depends=()
makedepends=('cargo')
-optdepends=()
provides=('just')
conflicts=('just')
-source=($pkgname::git+https://github.com/casey/just.git)
+source=(git+https://github.com/casey/just.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+ cd $pkgname
+ echo $(git describe|tr -d v).$(git rev-list --count HEAD)
}
build() {
- cd $pkgname
- cargo build --release
+ cd $pkgname
+ cargo build --release
}
package() {
- cd $pkgname
- install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
}