summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Thies2024-05-09 21:01:36 +0200
committerMichael Thies2024-05-09 21:01:36 +0200
commit150d651c29ee0ffb2da7df2b45678b18d4e3d8f2 (patch)
tree8755cfef9e9ea7608b02d734a3020cc293524505
parent71b9ff3f6e2fe95bb2970a778e42358cef3472c9 (diff)
downloadaur-150d651c29ee0ffb2da7df2b45678b18d4e3d8f2.tar.gz
Update to justbuild 1.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 774c8bc457a2..4e1170987653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = justbuild
pkgdesc = A generic build system supporting multi-repository builds
- pkgver = 1.2.5
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/just-buildsystem/justbuild
arch = x86_64
@@ -28,9 +28,9 @@ pkgbase = justbuild
conflicts = just
conflicts = just-git
conflicts = just-js
- source = justbuild-1.2.5.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v1.2.5.tar.gz
+ source = justbuild-1.3.0.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v1.3.0.tar.gz
source = gsl.pc
- sha256sums = 9f0c336fc333b64e77622b2956b4c9733f998e2b0db575827f492da87703efbe
- sha256sums = SKIP
+ sha256sums = 4f459ba5f88c2474c23bd3257a4a50653860c97fb5104750f2fdc3839f5c5d6f
+ sha256sums = c08f3e53356b1b258bb195ae0c2437f53269d7751d94800a46f75a3465346afe
pkgname = justbuild
diff --git a/PKGBUILD b/PKGBUILD
index 87f4439a808c..a8a4d524e4e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Thies <mail@mhthies.de>
pkgname=justbuild
-pkgver='1.2.5'
+pkgver='1.3.0'
pkgrel=1
pkgdesc="A generic build system supporting multi-repository builds"
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('gcc' 'wget' 'cli11' 'microsoft-gsl' 'nlohmann-json' 'pandoc')
conflicts=('just' 'just-git' 'just-js')
source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz"
"gsl.pc")
-sha256sums=('9f0c336fc333b64e77622b2956b4c9733f998e2b0db575827f492da87703efbe'
- 'SKIP')
+sha256sums=('4f459ba5f88c2474c23bd3257a4a50653860c97fb5104750f2fdc3839f5c5d6f'
+ 'c08f3e53356b1b258bb195ae0c2437f53269d7751d94800a46f75a3465346afe')
build() {
cd "${srcdir}/justbuild-${pkgver}"
@@ -41,6 +41,7 @@ package() {
install -m 755 -Dt "${pkgdir}/usr/bin" "${srcdir}/build/out/bin/just"
install -m 755 -Dt "${pkgdir}/usr/bin" "${srcdir}/build/out/bin/just-mr"
install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-import-git.py" "${pkgdir}/usr/bin/just-import-git"
+ install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-deduplicate-repos.py" "${pkgdir}/usr/bin/just-deduplicate-repos"
# bash completion
mkdir -p "${pkgdir}"/usr/share/bash-completion/completions