summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Thies2023-08-14 17:54:46 +0200
committerMichael Thies2023-08-14 17:54:46 +0200
commit2956178c7b589e568d37ede0bcb74a47d619fe8d (patch)
tree096435401969daf28e1309ab19db6a4db75d070f
parent92848131b6d1c5b953258d071bdf663d6c08f97d (diff)
downloadaur-2956178c7b589e568d37ede0bcb74a47d619fe8d.tar.gz
Use native libgit2 Arch Linux package
Now, that the fix for https://github.com/libgit2/libgit2/issues/6553 is released and packaged in Arch Linux, we can use the packaged libgit2 for justbuild -- instead of downloading, building and static-linking it in the bootstrapping process.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4495820aa70d..83103b97655d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = justbuild
pkgdesc = A generic build system supporting multi-repository builds
pkgver = 1.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/just-buildsystem/justbuild
arch = x86_64
license = Apache
@@ -25,6 +25,7 @@ pkgbase = justbuild
depends = python
depends = protobuf
depends = libarchive
+ depends = libgit2
conflicts = just
conflicts = just-git
conflicts = just-js
diff --git a/PKGBUILD b/PKGBUILD
index 1b438c743475..19abebfb127d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=justbuild
pkgver='1.1.4'
-pkgrel=1
+pkgrel=2
pkgdesc="A generic build system supporting multi-repository builds"
arch=('x86_64')
url="https://github.com/just-buildsystem/justbuild"
license=('Apache')
-depends=('glibc' 'gcc-libs' 'fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf' 'libarchive')
+depends=('glibc' 'gcc-libs' 'fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf' 'libarchive' 'libgit2')
makedepends=('clang' 'binutils' 'wget' 'cli11' 'microsoft-gsl' 'nlohmann-json' 'pandoc')
conflicts=('just' 'just-git' 'just-js')
source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz"
@@ -23,15 +23,11 @@ build() {
mkdir -p "${srcdir}/build"
# Bootstrap just
- # We build against native local dependencies, except for libgit2. This is neccessary to avoid the following
- # regression in libgit2, until the fix is released in an upcoming version:
- # - Issue: https://github.com/libgit2/libgit2/issues/6553
- # - Fix: https://github.com/libgit2/libgit2/pull/6554
env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar", "FINAL_LDFLAGS": ["-Wl,-z,relro,-z,now"]}'\
PKG_CONFIG_PATH="${srcdir}"\
PACKAGE=YES\
LOCALBASE=/usr\
- NON_LOCAL_DEPS='["bazel_remote_apis", "google_apis", "com_github_libgit2_libgit2"]'\
+ NON_LOCAL_DEPS='["bazel_remote_apis", "google_apis"]'\
python3 ./bin/bootstrap.py . ${srcdir}/build
# Build compiled just-mr