summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Thies2023-06-02 23:45:30 +0200
committerMichael Thies2023-06-02 23:48:28 +0200
commitba912f093db63770a74b323ddbd9e049bf252f7c (patch)
treea707a5df3c0e38e84e519bbc4bf184400092fef7
parent232f1ff5d4adbc5c3378b87edd1ab11865e1a792 (diff)
downloadaur-ba912f093db63770a74b323ddbd9e049bf252f7c.tar.gz
Add custom pkg-config file for microsoft-gsl
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--gsl.pc4
3 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d161b861f76..c4bbd92422a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = justbuild
makedepends = cli11
makedepends = microsoft-gsl
makedepends = nlohmann-json
+ makedepends = pandoc
depends = fmt
depends = openssl
depends = zlib
@@ -25,6 +26,8 @@ pkgbase = justbuild
conflicts = just-git
conflicts = just-js
source = justbuild-1.1.1.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v1.1.1.tar.gz
+ source = gsl.pc
sha256sums = 75b7d92d233250fa9751542cf5020c10b20e178f898b3fe1294fc9013b4ad5fe
+ sha256sums = SKIP
pkgname = justbuild
diff --git a/PKGBUILD b/PKGBUILD
index 7575f271f75a..a4581dc5e7de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=('Apache')
depends=('fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf')
makedepends=('clang' 'binutils' 'wget' 'cli11' 'microsoft-gsl' 'nlohmann-json' 'pandoc')
conflicts=('just' 'just-git' 'just-js')
-source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz")
-sha256sums=('75b7d92d233250fa9751542cf5020c10b20e178f898b3fe1294fc9013b4ad5fe')
+source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz"
+ "gsl.pc")
+sha256sums=('75b7d92d233250fa9751542cf5020c10b20e178f898b3fe1294fc9013b4ad5fe'
+ 'SKIP')
build() {
cd "${srcdir}/justbuild-${pkgver}"
@@ -22,6 +24,7 @@ build() {
# Bootstrap just
env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}'\
+ PKG_CONFIG_PATH="${srcdir}"\
PACKAGE=YES\
LOCALBASE=/usr\
NON_LOCAL_DEPS='["bazel_remote_apis", "google_apis", "com_github_libgit2_libgit2"]'\
diff --git a/gsl.pc b/gsl.pc
new file mode 100644
index 000000000000..1ed9cd732454
--- /dev/null
+++ b/gsl.pc
@@ -0,0 +1,4 @@
+Name: Microsoft GSL
+Description: C++ Core Guidelines Support Library
+Version: 4.0.0
+Cflags: -I/usr/include