summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Thies2023-06-03 00:39:48 +0200
committerMichael Thies2023-06-03 00:40:05 +0200
commitc30e8281590fe7d84d17470cde1cb32f559bf290 (patch)
treec17c041c177ff8f4e694c428fbfbf8529aa457ae
parent495daf89b5508d33f84e279b55b3f1a3774c4d1d (diff)
downloadaur-c30e8281590fe7d84d17470cde1cb32f559bf290.tar.gz
Add missing dependency on libarchive and add RELRO for executables
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3076132422c..23e27ab1d2de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,6 +22,7 @@ pkgbase = justbuild
depends = curl
depends = python
depends = protobuf
+ depends = libarchive
conflicts = just
conflicts = just-git
conflicts = just-js
diff --git a/PKGBUILD b/PKGBUILD
index d12244b6ae96..2a171b3d7a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A generic build system supporting multi-repository builds"
arch=('x86_64')
url="https://github.com/just-buildsystem/justbuild"
license=('Apache')
-depends=('fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf')
+depends=('fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf' 'libarchive')
makedepends=('clang' 'binutils' 'wget' 'cli11' 'microsoft-gsl' 'nlohmann-json' 'pandoc')
conflicts=('just' 'just-git' 'just-js')
source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz"
@@ -27,7 +27,7 @@ build() {
# regression in libgit2, until the fix is released in an upcoming version:
# - Issue: https://github.com/libgit2/libgit2/issues/6553
# - Fix: https://github.com/libgit2/libgit2/pull/6554
- env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}'\
+ env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar", "FINAL_LDFLAGS": ["-Wl,-z,relro,-z,now"]}'\
PKG_CONFIG_PATH="${srcdir}"\
PACKAGE=YES\
LOCALBASE=/usr\