summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Thies2023-06-02 22:18:51 +0200
committerMichael Thies2023-06-02 22:18:51 +0200
commitca4fc32c20d91e503245433091a167440037892b (patch)
treeefc79c890b3f8e8a19b3c6d4bb6e366f3cfa2f91
parentbc71c7fda330f4dd83e36055f9f0273422d3c8f0 (diff)
downloadaur-ca4fc32c20d91e503245433091a167440037892b.tar.gz
Replace Python-based just-mr with building compiled just-mr
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f36bbd3acb1..ae9a2ac77bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,15 +20,19 @@ build() {
[[ -d "${srcdir}/build/dep_includes" ]] && rm -rf "${srcdir}/build"
mkdir -p "${srcdir}/build"
+ # Bootstrap just
env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}' python3 ./bin/bootstrap.py . "${srcdir}/build"
+ # Build compiled just-mr
+ python ./bin/just-mr.py --just "../build/out/bin/just" --always-file install 'installed just-mr' --output-dir ../build/out -D '{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}'
+
# convert man pages from orgmode to man
find "${srcdir}/justbuild-${pkgver}/share/man" -name "*.md" -exec sh -c 'pandoc --standalone --to man -o "${0%.md}.man" "${0}"' {} \;
}
package() {
install -m 755 -Dt "${pkgdir}/usr/bin" "${srcdir}/build/out/bin/just"
- install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-mr.py" "${pkgdir}/usr/bin/just-mr"
+ install -m 755 -Dt "${pkgdir}/usr/bin" "${srcdir}/build/out/bin/just-mr"
install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-import-git.py" "${pkgdir}/usr/bin/just-import-git"
# bash completion