summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSzilveszter Székely2015-10-22 21:50:08 +0100
committerSzilveszter Székely2016-04-26 17:10:59 +0100
commitc789d6d98b19861e448909970e49fd3251e675af (patch)
tree0405236085eca14aec1442eb256bca09bfab5139
downloadaur-c789d6d98b19861e448909970e49fd3251e675af.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD76
-rw-r--r--jutoh.install14
-rwxr-xr-xjutoh.sh3
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..258a81002db2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Fri Apr 22 19:44:34 UTC 2016
+pkgbase = jutoh
+ pkgdesc = An ebook creation tool
+ pkgver = 2.35
+ pkgrel = 1
+ url = http://www.jutoh.com
+ install = jutoh.install
+ arch = i686
+ arch = x86_64
+ license = custom: Jutoh
+ depends = gtk2
+ depends = libpng12
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = libjpeg6: jpeg support
+ optdepends = java-runtime: epubcheck support
+ replaces = jutoh-bin
+ source = jutoh.sh
+ md5sums = 9a66a3e0a4fbafe827aa52b4d8353aa9
+ source_i686 = http://www.jutoh.com/Jutoh-2.35-i386.tar.gz
+ md5sums_i686 = f820b46a95f19128c221cb886c2481e0
+ source_x86_64 = http://www.jutoh.com/Jutoh-2.35-x86_64.tar.gz
+ md5sums_x86_64 = 5a8c094d507a808364989742f990334c
+
+pkgname = jutoh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f28f49317d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Szilveszter Székely <szekelyszilv at gmail dot com>
+pkgname=jutoh
+pkgver=2.35
+pkgrel=1
+pkgdesc="An ebook creation tool"
+arch=('i686' 'x86_64')
+url="http://www.jutoh.com"
+license=('custom: Jutoh')
+depends=('gtk2' 'libpng12'
+ 'shared-mime-info' 'desktop-file-utils' 'xdg-utils'
+ 'hicolor-icon-theme')
+optdepends=('libjpeg6: jpeg support'
+ 'java-runtime: epubcheck support')
+replaces=('jutoh-bin')
+install=jutoh.install
+
+source=('jutoh.sh')
+source_i686=(http://www.jutoh.com/Jutoh-${pkgver}-i386.tar.gz)
+source_x86_64=(http://www.jutoh.com/Jutoh-${pkgver}-x86_64.tar.gz)
+
+md5sums=('9a66a3e0a4fbafe827aa52b4d8353aa9')
+md5sums_i686=('f820b46a95f19128c221cb886c2481e0')
+md5sums_x86_64=('5a8c094d507a808364989742f990334c')
+
+prepare() {
+ mkdir ${srcdir}/jutoh-data
+ cd ${srcdir}/jutoh-data
+ tar -xzf ${srcdir}/JutohData.tar.gz
+}
+
+package() {
+ msg2 "Copying executable"
+ install -Dm755 ${srcdir}/jutoh.sh ${pkgdir}/usr/bin/jutoh
+ install -Dm755 ${srcdir}/jutoh.sh ${pkgdir}/usr/bin/jutoh2
+
+ msg2 "Copying desktop file"
+ install -Dm644 ${srcdir}/jutoh-data/jutoh2.desktop \
+ ${pkgdir}/usr/share/applications/jutoh2.desktop
+ install -Dm644 ${srcdir}/jutoh-data/x-jutoh2.desktop \
+ ${pkgdir}/usr/share/mimelnk/application/x-jutoh2.desktop
+
+ msg2 "Copying icons"
+ for res in '16x16' '22x22' '32x32' '48x48' '128x128'; do
+ install -Dm644 ${srcdir}/jutoh-data/appicons/jutoh${res}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${res}/apps/jutoh2.png
+ done
+ for res in '16x16' '24x24' '32x32' '48x48' '128x128'; do
+ install -Dm644 ${srcdir}/jutoh-data/appicons/jutoh_document${res}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${res}/mimetypes/application-x-jutohproject.png
+ install -Dm644 ${srcdir}/jutoh-data/appicons/jutoh_document_script${res}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${res}/mimetypes/application-x-jutohscript.png
+ done
+ install -Dm644 ${srcdir}/jutoh-data/appicons/jutoh128x128.png \
+ ${pkgdir}/usr/share/pixmaps/jutoh2.png
+
+ msg2 "Copying mimetypes"
+ install -Dm644 ${srcdir}/jutoh-data/jutoh2.mime \
+ ${pkgdir}/usr/share/mime-info/jutoh2.mime
+ install -Dm644 ${srcdir}/jutoh-data/jutoh2.keys \
+ ${pkgdir}/usr/share/mime-info/jutoh2.keys
+ install -Dm644 ${srcdir}/jutoh-data/jutoh2.xml \
+ ${pkgdir}/usr/share/mime/packages/jutoh2.xml
+ install -Dm644 ${srcdir}/jutoh-data/jutoh2.applications \
+ ${pkgdir}/usr/share/application-registry/jutoh2.applications
+
+ msg2 "Copying licence"
+ install -Dm644 ${srcdir}/jutoh-data/license.txt \
+ ${pkgdir}/usr/share/licenses/jutoh-bin/LICENSE
+
+ msg2 "Copying files"
+ install -dm755 ${pkgdir}/usr/share/jutoh
+ cp -R ${srcdir}/jutoh-data/. $pkgdir/usr/share/jutoh
+
+ msg2 "Cleaning up files"
+ rm -r ${pkgdir}/usr/share/jutoh/{jutoh2.{applications,desktop,keys,mime,xml},jutoh_eeepc.xml,license.txt,x-jutoh2.desktop,appicons}
+}
diff --git a/jutoh.install b/jutoh.install
new file mode 100644
index 000000000000..82bde2e335ef
--- /dev/null
+++ b/jutoh.install
@@ -0,0 +1,14 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-mime-database usr/share/mime &>/dev/null
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}
diff --git a/jutoh.sh b/jutoh.sh
new file mode 100755
index 000000000000..38f6a10c2e64
--- /dev/null
+++ b/jutoh.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+JUTOHDIR=/usr/share/jutoh
+$JUTOHDIR/jutoh "$@"