summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 11:11:43 +1000
committerPhillip Smith2015-06-02 11:11:43 +1000
commit4ba8a9d5e101a5b4f6d14bd10e8531415f3de2ac (patch)
tree3a5ab6755c77d1a74e00193b95ae23aa7fcbe167
downloadaur-4ba8a9d5e101a5b4f6d14bd10e8531415f3de2ac.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--jwhois.patch10
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61bd6e68d854
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jwhois
+ pkgdesc = An Internet Whois client
+ pkgver = 4.0
+ pkgrel = 1
+ url = http://www.gnu.org/software/jwhois/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gdbm
+ depends = libidn
+ source = ftp://ftp.gnu.org/gnu/jwhois/jwhois-4.0.tar.gz
+ source = jwhois.patch
+ md5sums = 977d0ba90ee058a7998c94d933fc9546
+ md5sums = 7ce928db7ca3132bc97cadac6288a94e
+
+pkgname = jwhois
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d6e1d48e0ae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/jwhois-*.pkg.tar.xz
+/jwhois-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a84d2628a3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: erkaN kaplaN <erkan@linux-sevenler.org>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=jwhois
+pkgver=4.0
+pkgrel=1
+pkgdesc="An Internet Whois client"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/jwhois/"
+license=('GPL3')
+depends=('gdbm' 'libidn')
+source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+ "$pkgname.patch")
+md5sums=('977d0ba90ee058a7998c94d933fc9546'
+ '7ce928db7ca3132bc97cadac6288a94e')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -Np0 -i "$srcdir"/${pkgname}.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/jwhois.patch b/jwhois.patch
new file mode 100644
index 000000000000..b1e3bfe1bd5e
--- /dev/null
+++ b/jwhois.patch
@@ -0,0 +1,10 @@
+--- src/dns.c~ 2007-06-26 12:58:38.000000000 +0600
++++ src/dns.c 2009-10-13 17:28:46.233709651 +0600
+@@ -119,6 +119,7 @@
+ memset(&hints, 0, sizeof(hints));
+ hints.ai_family = PF_UNSPEC;
+
++ hints.ai_flags = AI_ADDRCONFIG;
+ hints.ai_socktype = SOCK_STREAM;
+ if (port)
+ sprintf(ascport, "%9.9d", port);