summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2016-06-15 10:18:31 +1000
committerPhillip Smith2016-06-15 10:18:31 +1000
commit60c72f62ea07c2af153743cc964ac0e33d3b2295 (patch)
treed3623bcd1db835ef48f1aebbae62b205f25f8986
parent845fd9488e87c02dfa444a71e9c6cf11faef2e80 (diff)
downloadaur-60c72f62ea07c2af153743cc964ac0e33d3b2295.tar.gz
upgpkg: jwhois 4.0-2 (fix finding service in /etc/services)
Thanks to @yhager: The sources are looking for a 'whois' entry in /etc/services, which does not exist on my system. I had to patch it to look for internic instead.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--jwhois.patch15
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61bd6e68d854..c17be91facf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 00:18:31 UTC 2016
pkgbase = jwhois
pkgdesc = An Internet Whois client
pkgver = 4.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/jwhois/
arch = i686
arch = x86_64
@@ -10,8 +12,8 @@ pkgbase = jwhois
depends = libidn
source = ftp://ftp.gnu.org/gnu/jwhois/jwhois-4.0.tar.gz
source = jwhois.patch
- md5sums = 977d0ba90ee058a7998c94d933fc9546
- md5sums = 7ce928db7ca3132bc97cadac6288a94e
+ sha256sums = fa9bb86782b915c6d730bb723f876dc9b345a617db375aaf3416ec22553cd64e
+ sha256sums = ae79266541d18ba6a7ca9d5eef9f2187b179c4ad88921ee77c9d369d968d6e26
pkgname = jwhois
diff --git a/PKGBUILD b/PKGBUILD
index e947bc186185..af3b55d29449 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=jwhois
pkgver=4.0
-pkgrel=1
+pkgrel=2
pkgdesc="An Internet Whois client"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/jwhois/"
@@ -23,8 +23,8 @@ license=('GPL3')
depends=('gdbm' 'libidn')
source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
"$pkgname.patch")
-md5sums=('977d0ba90ee058a7998c94d933fc9546'
- '7ce928db7ca3132bc97cadac6288a94e')
+sha256sums=('fa9bb86782b915c6d730bb723f876dc9b345a617db375aaf3416ec22553cd64e'
+ 'ae79266541d18ba6a7ca9d5eef9f2187b179c4ad88921ee77c9d369d968d6e26')
prepare() {
cd "$srcdir"/$pkgname-$pkgver
diff --git a/jwhois.patch b/jwhois.patch
index b1e3bfe1bd5e..34acd63940a3 100644
--- a/jwhois.patch
+++ b/jwhois.patch
@@ -1,9 +1,16 @@
---- src/dns.c~ 2007-06-26 12:58:38.000000000 +0600
-+++ src/dns.c 2009-10-13 17:28:46.233709651 +0600
-@@ -119,6 +119,7 @@
+--- src/dns.c~ 2007-06-25 23:58:38.000000000 -0700
++++ src/dns.c 2016-06-04 16:20:19.644865127 -0700
+@@ -113,12 +113,13 @@
+ lookup_host_addrinfo(struct addrinfo **res, const char *host, int port)
+ {
+ struct addrinfo hints;
+- char ascport[10] = "whois";
++ char ascport[10] = "nicname";
+ int error;
+
memset(&hints, 0, sizeof(hints));
hints.ai_family = PF_UNSPEC;
-
+
+ hints.ai_flags = AI_ADDRCONFIG;
hints.ai_socktype = SOCK_STREAM;
if (port)