summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-11-02 09:03:28 -0700
committerBrian Bidulock2015-11-02 09:03:28 -0700
commit1d37065e52412f4db662b17eef0a54b1a7ed353d (patch)
treeaed84c136a21cda629fe6fa80a06d01e0e1f858e
parent392d51379a3c9d14b3b0b97a6b5efc132b846105 (diff)
downloadaur-1d37065e52412f4db662b17eef0a54b1a7ed353d.tar.gz
version s1303-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c9e4405053..2302e43d5cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v7
+# Mon Nov 2 16:03:01 UTC 2015
pkgbase = jwm-git
pkgdesc = JWM is a light-weight window manager for the X11 Window System. Git version.
- pkgver = s1278.3.g9a33e3a
+ pkgver = s1303
pkgrel = 1
url = http://joewing.net/projects/jwm/
arch = i686
@@ -23,7 +25,7 @@ pkgbase = jwm-git
conflicts = jwm-snapshot
conflicts = jwm-flashfixed
conflicts = jwm-snapshot-lite
- source = git://github.com/joewing/jwm.git
+ source = jwm-git::git+https://github.com/joewing/jwm.git
md5sums = SKIP
pkgname = jwm-git
diff --git a/PKGBUILD b/PKGBUILD
index 1856f1481ddc..a12e1cdb5ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Corey Mwamba <contact.me@coreymwamba.co.uk>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Corey Mwamba <contact.me@coreymwamba.co.uk>
pkgname=jwm-git
-pkgver=s1278.3.g9a33e3a
+pkgver=s1303
pkgrel=1
pkgdesc="JWM is a light-weight window manager for the X11 Window System. Git version."
arch=('i686' 'x86_64')
@@ -12,21 +13,25 @@ provides=('jwm')
conflicts=('jwm' 'jwm-snapshot' 'jwm-flashfixed' 'jwm-snapshot-lite')
depends=('fribidi' 'librsvg' 'libxinerama' 'libxmu' 'libxext' 'libpng' 'libx11' 'libxft' 'libjpeg>=7' 'libxpm')
makedepends=('git')
-source=('git://github.com/joewing/jwm.git')
+source=("$pkgname::git+https://github.com/joewing/jwm.git")
md5sums=('SKIP')
-_gitname=jwm
pkgver() {
- cd $_gitname
+ cd $pkgname
# Use the tag of the last commit
git describe --always | sed 's|-|.|g'
}
+prepare() {
+ cd $pkgname
+ cp /usr/share/automake-1.15/config.sub .
+ cp /usr/share/automake-1.15/config.guess .
+ autoreconf
+}
build() {
- cd "$srcdir/$_gitname/"
- autoreconf
- ./configure prefix=/usr --sysconfdir=/etc
+ cd $pkgname
+ ./configure --prefix=/usr --sysconfdir=/etc
# --disable-icons disable icon support
#--disable-png disable PNG images
#--disable-cairo disable Cairo support
@@ -40,10 +45,10 @@ build() {
#--disable-xmu disable Xmu support
#--disable-xinerama disable Xinerama support
#--disable-nls do not use Native Language Support
- make
+ make V=0
}
package() {
- cd "$srcdir/$_gitname"
+ cd $pkgname
make DESTDIR="$pkgdir/" install
}