summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToni Tauro2024-01-06 13:07:07 +0100
committerToni Tauro2024-01-06 13:07:07 +0100
commitdcbbb7d821d757c4c0ca7ef5ae9421eff756cc66 (patch)
treee3a043af081d6d2ac0d471e32297e29b7114fe0c
parent37a57f54d6757df653c93b87d31d9a46d39890da (diff)
downloadaur-dcbbb7d821d757c4c0ca7ef5ae9421eff756cc66.tar.gz
chore(update): v0.17.1
Signed-off-by: Toni Tauro <eye@eyenx.ch>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21c37e878cae..437ca9e111bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = k0sctl-bin
pkgdesc = A bootstrapping and management tool for k0s clusters.
- pkgver = 0.16.0
+ pkgver = 0.17.1
pkgrel = 1
url = https://github.com/k0sproject/k0sctl
arch = x86_64
license = Apache
options = !strip
- source = k0sctl-linux-x64-0.16.0::https://github.com/k0sproject/k0sctl/releases/download/v0.16.0/k0sctl-linux-x64
- sha256sums = b21eb9edc90180d3bfb3413b82efac3811989f85d5c1f8e54750bf7b2144fbc6
+ source = k0sctl-linux-x64-0.17.1::https://github.com/k0sproject/k0sctl/releases/download/v0.17.1/k0sctl-linux-x64
+ sha256sums = 88dfa553d44c9826702b410bf2e3d927d7cd42006aaa5175158f148e7de33c1b
pkgname = k0sctl-bin
diff --git a/PKGBUILD b/PKGBUILD
index b83bb77702da..d7e1bf1c5ea4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Co-Maintainer: Lukas Grossar <lukasgrossar@gmail.com>
pkgname=k0sctl-bin
-pkgver=0.16.0
+pkgver=0.17.1
pkgrel=1
pkgdesc="A bootstrapping and management tool for k0s clusters."
arch=('x86_64')
url="https://github.com/k0sproject/k0sctl"
license=('Apache')
source=("k0sctl-linux-x64-$pkgver::https://github.com/k0sproject/k0sctl/releases/download/v${pkgver}/k0sctl-linux-x64")
-sha256sums=('b21eb9edc90180d3bfb3413b82efac3811989f85d5c1f8e54750bf7b2144fbc6')
+sha256sums=('88dfa553d44c9826702b410bf2e3d927d7cd42006aaa5175158f148e7de33c1b')
options=(!strip)
package() {
- install -Dm 755 "$srcdir/k0sctl-linux-x64-$pkgver" "$pkgdir/usr/bin/k0sctl"
+ install -Dm 755 "$srcdir/k0sctl-linux-x64-$pkgver" "$pkgdir/usr/bin/k0sctl"
- "$pkgdir/usr/bin/k0sctl" completion --shell bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/k0sctl"
- "$pkgdir/usr/bin/k0sctl" completion --shell zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_k0sctl"
- "$pkgdir/usr/bin/k0sctl" completion --shell fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/k0sctl.fish"
+ "$pkgdir/usr/bin/k0sctl" completion --shell bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/k0sctl"
+ "$pkgdir/usr/bin/k0sctl" completion --shell zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_k0sctl"
+ "$pkgdir/usr/bin/k0sctl" completion --shell fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/k0sctl.fish"
}