summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2023-12-23 08:43:12 +0300
committerIvan Shapovalov2023-12-23 08:44:02 +0300
commit992467c6183acdc671a41d706d75ac9e70273b44 (patch)
tree7b6bd2c7420219174fcab648fc74180939c286a1
parentc07d448f7e1b078b85fd55a6245c350d47dab07c (diff)
downloadaur-992467c6183acdc671a41d706d75ac9e70273b44.tar.gz
Convert to fixed release package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f10074409bc..5f134d39152b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = k3s-git
+pkgbase = k3s
pkgdesc = Lightweight Kubernetes
- pkgver = 1.29.0+k3s1+r0+g3190a5faa2
+ pkgver = 1.29.0+k3s1
pkgrel = 1
url = https://k3s.io
arch = x86_64
@@ -8,12 +8,10 @@ pkgbase = k3s-git
makedepends = git
makedepends = go
makedepends = podman
- provides = k3s
- conflicts = k3s
backup = etc/systemd/system/k3s.service.env
backup = etc/systemd/system/k3s-agent.service.env
backup = etc/rancher/k3s/config.yaml
- source = git+https://github.com/k3s-io/k3s
+ source = git+https://github.com/k3s-io/k3s#tag=v1.29.0+k3s1
source = k3s.service.env
source = k3s-agent.service.env
source = config.yaml
@@ -38,4 +36,4 @@ pkgbase = k3s-git
sha256sums = bb721e8850eb736ad9aad4f0a8ef20dac0e06d7731731c3541264f138be28b74
sha256sums = f448303dbbefef2645b8c2146d595643c0143c7300eab12a459b85a3b18b3d91
-pkgname = k3s-git
+pkgname = k3s
diff --git a/PKGBUILD b/PKGBUILD
index 9d9f7b997080..d1ec6dbd64e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
-pkgname=k3s-git
-pkgver=1.29.0+k3s1+r0+g3190a5faa2
+pkgname=k3s
+pkgver=1.29.0+k3s1
pkgrel=1
pkgdesc='Lightweight Kubernetes'
arch=(x86_64)
@@ -13,15 +13,13 @@ makedepends=(
# docker container during the officially blessed build path
# curl jq yq zstd pigz
)
-provides=(k3s)
-conflicts=(k3s)
backup=(
etc/systemd/system/k3s.service.env
etc/systemd/system/k3s-agent.service.env
etc/rancher/k3s/config.yaml
)
source=(
- "git+https://github.com/k3s-io/k3s"
+ "git+https://github.com/k3s-io/k3s#tag=v${pkgver}"
'k3s.service.env'
'k3s-agent.service.env'
'config.yaml'
@@ -47,11 +45,6 @@ sha256sums=('SKIP'
'bb721e8850eb736ad9aad4f0a8ef20dac0e06d7731731c3541264f138be28b74'
'f448303dbbefef2645b8c2146d595643c0143c7300eab12a459b85a3b18b3d91')
-pkgver() {
- cd k3s
- git describe --long --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
-}
-
prepare() {
cd k3s