summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney Bouchaud2021-07-27 10:27:01 +0200
committerVianney Bouchaud2021-07-27 10:27:01 +0200
commitceb6446e091c7932ce697ff20ee84e8fe8720500 (patch)
tree44d29826746a64a8df741579fad42254f1bfff6b
downloadaur-ceb6446e091c7932ce697ff20ee84e8fe8720500.tar.gz
creating package for k8s-ldap-auth
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD36
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9803f3c6981b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = k8s-ldap-auth
+ pkgdesc = Kubernetes webhook token authentication plugin implementation using ldap.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/vbouchaud/k8s-ldap-auth
+ arch = x86_64
+ arch = armv7l
+ arch = armv7h
+ arch = aarch64
+ license = MPL2
+ makedepends = go
+ source = k8s-ldap-auth-2.0.0.tar.gz::https://github.com/vbouchaud/k8s-ldap-auth/archive/v2.0.0.tar.gz
+ sha256sums = 9397ad92d6910b922cb501ef02b52a2b20f6a4f1476f62500fbdd29dae2031c6
+
+pkgname = k8s-ldap-auth
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..935dd640d2f0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/k8s-ldap-auth*
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab18585274b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Vianney Bouchaud <aur dot vianney at bouchaud dot org>
+
+pkgname=k8s-ldap-auth
+pkgdesc="Kubernetes webhook token authentication plugin implementation using ldap."
+pkgver=2.0.0
+pkgrel=1
+arch=('x86_64' 'armv7l' 'armv7h' 'aarch64')
+url="https://github.com/vbouchaud/k8s-ldap-auth"
+license=('MPL2')
+makedepends=(
+ 'go'
+)
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/vbouchaud/k8s-ldap-auth/archive/v${pkgver}.tar.gz"
+)
+
+sha256sums=(
+ "9397ad92d6910b922cb501ef02b52a2b20f6a4f1476f62500fbdd29dae2031c6"
+)
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "$srcdir/$pkgname-$pkgver"
+ make VERSION=v$pkgver k8s-ldap-auth
+}
+
+package() {
+ install -D -m0755 "${srcdir}/$pkgname-$pkgver/k8s-ldap-auth" "${pkgdir}/usr/bin/k8s-ldap-auth"
+}