summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney Bouchaud2022-03-29 14:14:45 +0200
committerVianney Bouchaud2022-03-29 14:14:45 +0200
commitf4e3701c1b74f62f7ffbf39d23486a3879e0a4cf (patch)
tree3d323157d4fd569b5ea219e31aca5a527b2ed7c9
parentac604337378fb204893f9e7531dda2a9985247de (diff)
downloadaur-f4e3701c1b74f62f7ffbf39d23486a3879e0a4cf.tar.gz
upgpkg: k8s-ldap-auth-bin 4.0.0-1
upstream release upgpkg: k8s-ldap-auth-git 4.0.0.r0.gef268b9-1 upstream release upgpkg: k8s-ldap-auth 4.0.0-1 upstream release bumping k8s-ldap-auth related packages to v4.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc7f82cc9b2..1715c9f766ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = k8s-ldap-auth
pkgdesc = Kubernetes webhook token authentication plugin implementation using ldap.
- pkgver = 3.2.1
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/vbouchaud/k8s-ldap-auth
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = k8s-ldap-auth
arch = aarch64
license = MPL2
makedepends = go
- source = k8s-ldap-auth-3.2.1.tar.gz::https://github.com/vbouchaud/k8s-ldap-auth/archive/v3.2.1.tar.gz
- sha256sums = 2517c85e6c6e0aebd0062e3e5391511f7b50d6d4237796426e2f1ffb17a7b94d
+ source = k8s-ldap-auth-4.0.0.tar.gz::https://github.com/vbouchaud/k8s-ldap-auth/archive/v4.0.0.tar.gz
+ sha256sums = 404606ac6ce95ceebbc30e5df1fc2a4dbec50cdf00e26c907129677903f7340b
pkgname = k8s-ldap-auth
diff --git a/PKGBUILD b/PKGBUILD
index 9206ec172471..08b8ed3ee995 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=k8s-ldap-auth
pkgdesc="Kubernetes webhook token authentication plugin implementation using ldap."
-pkgver=3.2.1
+pkgver=4.0.0
pkgrel=1
arch=('x86_64' 'armv7l' 'armv7h' 'aarch64')
url="https://github.com/vbouchaud/k8s-ldap-auth"
@@ -16,21 +16,21 @@ source=(
)
sha256sums=(
- "2517c85e6c6e0aebd0062e3e5391511f7b50d6d4237796426e2f1ffb17a7b94d"
+ "404606ac6ce95ceebbc30e5df1fc2a4dbec50cdf00e26c907129677903f7340b"
)
build() {
- export GOPATH="$srcdir"/gopath
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export CGO_ENABLED=1
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
- cd "$srcdir/$pkgname-$pkgver"
- make VERSION=v$pkgver k8s-ldap-auth
+ cd "$srcdir/$pkgname-$pkgver"
+ make VERSION=v$pkgver k8s-ldap-auth
}
package() {
- install -D -m0755 "${srcdir}/$pkgname-$pkgver/k8s-ldap-auth" "${pkgdir}/usr/bin/k8s-ldap-auth"
+ install -D -m0755 "${srcdir}/$pkgname-$pkgver/k8s-ldap-auth" "${pkgdir}/usr/bin/k8s-ldap-auth"
}