summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Goudry2023-06-16 17:19:28 +0200
committerNicolas Goudry2023-06-16 17:25:32 +0200
commit01af63f5e9719168ba7eb7577a3e1314c21134d7 (patch)
tree264d643055795ab2324e092974271cd530297986
downloadaur-01af63f5e9719168ba7eb7577a3e1314c21134d7.tar.gz
chore: initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7dfad34b56c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = k8sgpt-git
+ pkgdesc = Giving Kubernetes Superpowers to everyone
+ pkgver = v0.3.8.r3.g0f03ddc
+ pkgrel = 1
+ url = http://k8sgpt.ai/
+ arch = x86_64
+ arch = arm64
+ arch = i386
+ license = Apache
+ makedepends = go
+ makedepends = git
+ provides = k8sgpt
+ conflicts = k8sgpt
+ source = git+https://github.com/k8sgpt-ai/k8sgpt.git
+ sha256sums = SKIP
+
+pkgname = k8sgpt-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc6650b691fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.zst
+k8sgpt
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d255bcb30b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nicolas Goudry <goudry.nicolas@gmail.com>
+pkgname=k8sgpt-git
+_pkgname=k8sgpt
+pkgver=v0.3.8.r3.g0f03ddc
+pkgrel=1
+pkgdesc="Giving Kubernetes Superpowers to everyone"
+arch=('x86_64' 'arm64' 'i386')
+url="http://k8sgpt.ai/"
+conflicts=('k8sgpt')
+provides=('k8sgpt')
+options=()
+license=('Apache')
+makedepends=('go' 'git')
+source=("git+https://github.com/k8sgpt-ai/k8sgpt.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make tidy cover build
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${srcdir}/${_pkgname}"/LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}