summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlefrade2020-11-02 06:17:48 +0300
committerlefrade2020-11-02 06:17:48 +0300
commit61b49d4c14dc141a65ad4eb13d1bb8f5f45eb1c5 (patch)
tree93376b08f1481a906ce111f23d31cb39f7bfe358
downloadaur-61b49d4c14dc141a65ad4eb13d1bb8f5f45eb1c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebc3cd2301a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kadimus-git
+ pkgdesc = A tool to check and exploit lfi vulnerability
+ pkgver = 1.5.r7.gac5f438
+ pkgrel = 1
+ url = https://github.com/P0cL4bs/kadimus
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = pcre
+ depends = libssh
+ provides = kadimus
+ conflicts = kadimus
+ source = git+https://github.com/P0cL4bs/kadimus.git
+ md5sums = SKIP
+
+pkgname = kadimus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d9feeef4453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lefrade <lefrade@pm.me>
+
+_pkgname=kadimus
+pkgname="$_pkgname-git"
+pkgver=1.5.r7.gac5f438
+pkgrel=1
+pkgdesc='A tool to check and exploit lfi vulnerability'
+arch=('i686' 'x86_64')
+url='https://github.com/P0cL4bs/kadimus'
+license=('MIT')
+depends=('curl' 'pcre' 'libssh')
+makedepends=('git')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+source=('git+https://github.com/P0cL4bs/kadimus.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/^v//g;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 'license.txt' "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}