summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772022-01-23 18:10:49 +0100
committerThor772022-01-23 18:10:49 +0100
commitb57ecc9e8b9333f4e22870f883bd83e798b5b041 (patch)
treedb296955966ae91bfe6bf8b32b0ca5a961b99e2a
parentc67ccb64457a76888920533c72a5fca66f72d237 (diff)
downloadaur-b57ecc9e8b9333f4e22870f883bd83e798b5b041.tar.gz
Explicitly enable curl to follow redirects
thanks to kaspermarkus for the report https://aur.archlinux.org/packages/kafka/#comment-847896
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ff61dc5f701..8fd61b6df89f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kafka
pkgdesc = A high-throughput distributed messaging system
pkgver = 2.12_3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://kafka.apache.org/
install = install_kafka.sh
arch = any
@@ -20,7 +20,7 @@ pkgbase = kafka
backup = etc/kafka/producer.properties
backup = etc/kafka/server.properties
backup = etc/kafka/tools-log4j.properties
- source = https://ftp.halifax.rwth-aachen.de/apache///kafka/3.0.0/kafka_2.12-3.0.0.tgz
+ source = https://dlcdn.apache.org///kafka/3.0.0/kafka_2.12-3.0.0.tgz
source = zookeeper_log4j.properties
source = systemd_kafka.service
source = systemd_sysusers.d_kafka.conf
diff --git a/PKGBUILD b/PKGBUILD
index bceff605426b..82adb8b1a344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _scalaver=2.12
_appver=3.0.0
pkgver=${_scalaver}_${_appver}
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc='A high-throughput distributed messaging system'
arch=('any')
url='https://kafka.apache.org/'
@@ -32,7 +32,7 @@ backup=(etc/kafka/connect-console-sink.properties
install=install_kafka.sh
_apache_cgi="http://www.apache.org/dyn/closer.cgi"
-_closest=$(curl "${_apache_cgi}?asjson=1" | tr -d '\n ' | sed -r 's/.*"preferred":"(.+)".*/\1/')
+_closest=$(curl -Li "${_apache_cgi}?asjson=1" | tr -d '\n ' | sed -r 's/.*"preferred":"(.+)".*/\1/')
_app_path="/${pkgname}/${_appver}/${pkgname}_${_pkgver}.tgz"
source=(${_closest}/${_app_path}
zookeeper_log4j.properties