summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Koftun2019-11-13 13:57:15 +0100
committerLeonid Koftun2019-11-13 13:57:15 +0100
commit1788f568e4f28c7e5131c5a8fd227cabede7d2ad (patch)
tree82d9b2a77247b4a3fea31acd8f8c9aa86c04c167
downloadaur-1788f568e4f28c7e5131c5a8fd227cabede7d2ad.tar.gz
Initial commit with kafkactl 1.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38ba045a0dc3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kafkactl
+ pkgdesc = Command Line Tool for managing Apache Kafka
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/deviceinsight/kafkactl
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ depends = glibc
+ source = https://github.com/deviceinsight/kafkactl/archive/1.3.0.tar.gz
+ sha256sums = 99b19bd0fb33dc46d62034962934a9cb8463efd2cc422f35f2c6a64bc0deeb2c
+
+pkgname = kafkactl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf968b094f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Leonid Koftun <leonid.koftun@gmail.com>
+
+pkgname=kafkactl
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Command Line Tool for managing Apache Kafka'
+arch=('i686' 'x86_64')
+url="https://github.com/deviceinsight/kafkactl"
+license=('Apache')
+makedepends=('go')
+depends=('glibc')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('99b19bd0fb33dc46d62034962934a9cb8463efd2cc422f35f2c6a64bc0deeb2c')
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}