summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-07-09 12:10:24 +0000
committerAntonio Rojas2019-07-09 12:10:24 +0000
commitdb8343576dd8795cece6cc7e0804c668645a1588 (patch)
treea88c99740199cbb9b24fb3ef17bf3e642ab25ab7
downloadaur-db8343576dd8795cece6cc7e0804c668645a1588.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87f5ee274cbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kaidan
+ pkgdesc = A user-friendly XMPP client for every device
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://www.kaidan.im/
+ arch = x86_64
+ license = GPL3
+ license = MIT
+ makedepends = extra-cmake-modules
+ depends = knotifications
+ depends = kirigami2
+ depends = qt5-svg
+ depends = qxmpp
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ source = https://download.kde.org/stable/kaidan/0.4.0/kaidan-0.4.0.tar.xz
+ source = https://download.kde.org/stable/kaidan/0.4.0/kaidan-0.4.0.tar.xz.sig
+ validpgpkeys = 03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B
+ sha256sums = c2ec16d2acfb4c62d3eef652e492a7267124148d458321436eaf1916e8ed4d9e
+ sha256sums = SKIP
+
+pkgname = kaidan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4598f7141cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=kaidan
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A user-friendly XMPP client for every device"
+arch=(x86_64)
+url="https://www.kaidan.im/"
+license=(GPL3 MIT)
+depends=(knotifications kirigami2 qt5-svg qxmpp desktop-file-utils hicolor-icon-theme)
+makedepends=(extra-cmake-modules)
+source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('c2ec16d2acfb4c62d3eef652e492a7267124148d458321436eaf1916e8ed4d9e'
+ 'SKIP')
+validpgpkeys=(03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B) # Linus Jahn <lnj@kaidan.im>
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir"/$pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}