summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcourk2018-03-04 15:31:44 +0100
committercourk2018-03-04 15:31:44 +0100
commitcd93002d68e174f7565464391ac1afe887cf21ea (patch)
tree8396ac0f14b34c77df3267c4c37de86244f5db07
parentf69ef2d6f8b096869396b1fab94338161b39f2e9 (diff)
downloadaur-cd93002d68e174f7565464391ac1afe887cf21ea.tar.gz
Updated version (0.7 -> 0.8)
-rw-r--r--.SRCINFO8
-rw-r--r--01-fix_lib_dir.patch9
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b7706bb0c99..73402b88893c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = kaitai-struct-compiler
pkgdesc = Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language
- pkgver = 0.7
+ pkgver = 0.8
pkgrel = 1
url = http://kaitai.io/
arch = any
license = GPL3
depends = java-runtime
- source = kaitai-struct-compiler-0.7.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=0.7%2Fkaitai-struct-compiler-0.7.zip
+ source = kaitai-struct-compiler-0.8.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=0.8%2Fkaitai-struct-compiler-0.8.zip
source = 01-fix_lib_dir.patch
- sha1sums = 6df04de01a22b2a5853b286c84c893681c407936
- sha1sums = f195c30032c7b2b8f9e2322188b698248bc27adf
+ sha1sums = be72b5bfabd1f54a7ed5311d35dffca17d034708
+ sha1sums = e56da0a1c29e23802786e6811c9ee5652174d7c3
pkgname = kaitai-struct-compiler
diff --git a/01-fix_lib_dir.patch b/01-fix_lib_dir.patch
index 1ad62a65bfd6..46289d994fcc 100644
--- a/01-fix_lib_dir.patch
+++ b/01-fix_lib_dir.patch
@@ -1,11 +1,12 @@
---- kaitai-struct-compiler-0.7.pristine/bin/kaitai-struct-compiler 2017-03-27 12:03:24.360256586 +0200
-+++ kaitai-struct-compiler-0.7.new/bin/kaitai-struct-compiler 2017-03-27 12:04:03.948294633 +0200
-@@ -332,7 +332,7 @@
+diff -purN kaitai-struct-compiler-0.8/bin/kaitai-struct-compiler kaitai-struct-compiler-0.8.new/bin/kaitai-struct-compiler
+--- kaitai-struct-compiler-0.8/bin/kaitai-struct-compiler 2018-02-05 02:16:20.000000000 +0100
++++ kaitai-struct-compiler-0.8.new/bin/kaitai-struct-compiler 2018-03-04 15:15:23.311979371 +0100
+@@ -334,7 +334,7 @@ declare -a app_commands
declare -r real_script_path="$(realpath "$0")"
declare -r app_home="$(realpath "$(dirname "$real_script_path")")"
# TODO - Check whether this is ok in cygwin...
-declare -r lib_dir="$(realpath "${app_home}/../lib")"
+declare -r lib_dir="/usr/share/java/kaitai-struct-compiler"
- declare -a app_mainclass=("io.kaitai.struct.JavaMain")
+ declare -a app_mainclass=(io.kaitai.struct.JavaMain)
declare -r script_conf_file="${app_home}/../conf/application.ini"
diff --git a/PKGBUILD b/PKGBUILD
index 4a1b82a7f2f4..d8ce300e1a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: courk <courk at courk dot fr>
pkgname=kaitai-struct-compiler
-pkgver=0.7
+pkgver=0.8
pkgrel=1
pkgdesc="Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language"
arch=(any)
@@ -9,8 +9,8 @@ license=('GPL3')
depends=("java-runtime")
optdepends=()
source=("$pkgname-$pkgver.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=$pkgver%2F$pkgname-$pkgver.zip" "01-fix_lib_dir.patch")
-sha1sums=("6df04de01a22b2a5853b286c84c893681c407936"
- "f195c30032c7b2b8f9e2322188b698248bc27adf")
+sha1sums=("be72b5bfabd1f54a7ed5311d35dffca17d034708"
+ "e56da0a1c29e23802786e6811c9ee5652174d7c3")
prepare() {
cd $pkgname-$pkgver