summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcourk2017-01-19 19:10:50 +0100
committercourk2017-01-19 19:10:50 +0100
commitd6d00febdbb4d31aea3f9a0dee4875722d3bdf9d (patch)
tree90bac9dc51c9fafe0b5eb43a4eab6cc4409d95b4
downloadaur-d6d00febdbb4d31aea3f9a0dee4875722d3bdf9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rwxr-xr-xkaitai-struct-compiler12
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eee53384479b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kaitai-struct-compiler
+ pkgdesc = Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://kaitai.io/
+ arch = any
+ license = GPL3
+ depends = java-runtime
+ source = kaitai-struct-compiler-0.5.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=0.5%2Fkaitai-struct-compiler-0.5.zip
+ source = kaitai-struct-compiler
+ sha1sums = 2df2f889233df6856ed98f0ab453bafe8c736512
+ sha1sums = 834551bc7e7b4ef645614a6a0d24c550a46dde74
+
+pkgname = kaitai-struct-compiler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b167f3c06e4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: courk <courk at courk dot fr>
+pkgname=kaitai-struct-compiler
+pkgver=0.5
+pkgrel=1
+pkgdesc="Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language"
+arch=(any)
+url="http://kaitai.io/"
+license=('GPL3')
+depends=("java-runtime")
+optdepends=()
+source=("$pkgname-$pkgver.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=$pkgver%2F$pkgname-$pkgver.zip" "kaitai-struct-compiler")
+sha1sums=("2df2f889233df6856ed98f0ab453bafe8c736512"
+ "834551bc7e7b4ef645614a6a0d24c550a46dde74")
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/lib/"
+ for f in *.jar
+ do
+ install -D -m 644 "$f" "$pkgdir/usr/share/java/$pkgname/$f"
+ done
+ cd "$srcdir"
+ install -D -m 755 "kaitai-struct-compiler" "$pkgdir/usr/bin/kaitai-struct-compiler"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/kaitai-struct-compiler b/kaitai-struct-compiler
new file mode 100755
index 000000000000..bb13512569d7
--- /dev/null
+++ b/kaitai-struct-compiler
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+LIBS=/usr/share/java/kaitai-struct-compiler/*
+LIBS_STR=""
+
+for f in $LIBS
+do
+ LIBS_STR="$LIBS_STR:$f"
+done
+
+java -cp "$LIBS_STR" io.kaitai.struct.Main "$@"
+