summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcourk2017-03-27 12:14:26 +0200
committercourk2017-03-27 12:14:26 +0200
commitf69ef2d6f8b096869396b1fab94338161b39f2e9 (patch)
tree39bdd535b637025c5e799e269b13b49c63e6525b
parentf814d5860d66f9e1049fa27686dce645f214ef0c (diff)
downloadaur-f69ef2d6f8b096869396b1fab94338161b39f2e9.tar.gz
Updated version (0.6 -> 0.7)
-rw-r--r--.SRCINFO8
-rw-r--r--01-fix_lib_dir.patch7
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2473141dacc2..4b7706bb0c99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = kaitai-struct-compiler
pkgdesc = Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language
- pkgver = 0.6
+ pkgver = 0.7
pkgrel = 1
url = http://kaitai.io/
arch = any
license = GPL3
depends = java-runtime
- source = kaitai-struct-compiler-0.6.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=0.6%2Fkaitai-struct-compiler-0.6.zip
+ source = kaitai-struct-compiler-0.7.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=0.7%2Fkaitai-struct-compiler-0.7.zip
source = 01-fix_lib_dir.patch
- sha1sums = e60d40b7fba5a9f84cb9a9d87f491a7c8e5096bd
- sha1sums = 48c0e5d2682c61d4cea023d19882eb92c191cc1a
+ sha1sums = 6df04de01a22b2a5853b286c84c893681c407936
+ sha1sums = f195c30032c7b2b8f9e2322188b698248bc27adf
pkgname = kaitai-struct-compiler
diff --git a/01-fix_lib_dir.patch b/01-fix_lib_dir.patch
index 4ec875b6cf64..1ad62a65bfd6 100644
--- a/01-fix_lib_dir.patch
+++ b/01-fix_lib_dir.patch
@@ -1,12 +1,11 @@
-diff -aur kaitai-struct-compiler-0.5.pristine/bin/kaitai-struct-compiler kaitai-struct-compiler-0.5.new/bin/kaitai-struct-compiler
---- kaitai-struct-compiler-0.5.pristine/bin/kaitai-struct-compiler 2017-01-20 15:48:53.379117710 +0100
-+++ kaitai-struct-compiler-0.5.new/bin/kaitai-struct-compiler 2017-01-20 15:50:03.335780612 +0100
+--- kaitai-struct-compiler-0.7.pristine/bin/kaitai-struct-compiler 2017-03-27 12:03:24.360256586 +0200
++++ kaitai-struct-compiler-0.7.new/bin/kaitai-struct-compiler 2017-03-27 12:04:03.948294633 +0200
@@ -332,7 +332,7 @@
declare -r real_script_path="$(realpath "$0")"
declare -r app_home="$(realpath "$(dirname "$real_script_path")")"
# TODO - Check whether this is ok in cygwin...
-declare -r lib_dir="$(realpath "${app_home}/../lib")"
+declare -r lib_dir="/usr/share/java/kaitai-struct-compiler"
- declare -a app_mainclass=("io.kaitai.struct.Main")
+ declare -a app_mainclass=("io.kaitai.struct.JavaMain")
declare -r script_conf_file="${app_home}/../conf/application.ini"
diff --git a/PKGBUILD b/PKGBUILD
index c958d6eb5b99..4a1b82a7f2f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: courk <courk at courk dot fr>
pkgname=kaitai-struct-compiler
-pkgver=0.6
+pkgver=0.7
pkgrel=1
pkgdesc="Kaitai Struct Compiler: Compiler for the Kaitai declarative binary format parsing language"
arch=(any)
@@ -9,8 +9,8 @@ license=('GPL3')
depends=("java-runtime")
optdepends=()
source=("$pkgname-$pkgver.zip::https://bintray.com/kaitai-io/universal/download_file?file_path=$pkgver%2F$pkgname-$pkgver.zip" "01-fix_lib_dir.patch")
-sha1sums=("e60d40b7fba5a9f84cb9a9d87f491a7c8e5096bd"
- "48c0e5d2682c61d4cea023d19882eb92c191cc1a")
+sha1sums=("6df04de01a22b2a5853b286c84c893681c407936"
+ "f195c30032c7b2b8f9e2322188b698248bc27adf")
prepare() {
cd $pkgname-$pkgver