summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-17 15:21:35 +0800
committerzxp198210052023-11-17 15:21:35 +0800
commit00949fab3bfe76c5cb51e10457e1f8a6cd5ced8b (patch)
treedead29235eec7acba75193ab48d856b70b7c36e4
parent8e7af87992a53beb29281b726fcf114203aff417 (diff)
downloadaur-00949fab3bfe76c5cb51e10457e1f8a6cd5ced8b.tar.gz
update to 2023-46
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD69
-rwxr-xr-xprepare_pkg.sh7
3 files changed, 49 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f53cd04f5ea9..953efa29d030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
pkgbase = kaiteki-bin
pkgdesc = A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support
- pkgver = 2023_44
+ pkgver = 2023_46
pkgrel = 1
url = https://kaiteki.app
arch = x86_64
license = AGPL3
- depends = glibc
- depends = gcc-libs
+ makedepends = gendesk
depends = gtk3
depends = libhandy
- provides = kaiteki
- source = kaiteki-bin-2023_44::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-44/linux.zip
- sha256sums = b5299f302e25eac2aef47d3d9b723e5bc56e9862e86e3d6d694761645ec81fa4
+ depends = at-spi2-core
+ depends = cairo
+ depends = libepoxy
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = fontconfig
+ provides = Kaiteki
+ source = kaiteki-2023_46.zip::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-46/linux.zip
+ source = kaiteki.png::https://raw.githubusercontent.com/Kaiteki-Fedi/Kaiteki/weekly-2023-46/src/kaiteki/assets/icon.png
+ sha256sums = ab7d6f9b6a064d334db204ee6beb328b2457c71096ecbdcebaec94a270cd9957
+ sha256sums = dc6b22558692d50f71113dbcbfed6382892cc2a27444cdacde03099297f36e3e
pkgname = kaiteki-bin
diff --git a/PKGBUILD b/PKGBUILD
index 619c364503a7..1ff3e023653d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,42 @@
-# Maintainer: Siavash Askari Nasr <ciavash@protonmail.com>
-
-_app_name=kaiteki
-pkgname="${_app_name}-bin"
-pkgver=2023_44
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Siavash Askari Nasr <ciavash@protonmail.com>
+pkgname=kaiteki-bin
+_pkgname=Kaiteki
+pkgver=2023_46
pkgrel=1
pkgdesc="A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support"
arch=('x86_64')
url='https://kaiteki.app'
+_ghurl=https://github.com/Kaiteki-Fedi/Kaiteki
license=('AGPL3')
-provides=("${_app_name}")
-depends=(glibc gcc-libs gtk3 libhandy)
-source=("${pkgname}-${pkgver}::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-${pkgver//_/-}/linux.zip")
-sha256sums=('b5299f302e25eac2aef47d3d9b723e5bc56e9862e86e3d6d694761645ec81fa4')
-
-package() {
- local _opt_app_dir="/opt/${_app_name}"
-
- install -dm755 "${pkgdir}${_opt_app_dir}" "${pkgdir}/usr/bin/"
-
- mv linux/{data,lib,"${_app_name}"} "${pkgdir}${_opt_app_dir}"
- chmod 755 "${pkgdir}${_opt_app_dir}/${_app_name}"
-
- ln -s "${_opt_app_dir}/${_app_name}" "${pkgdir}/usr/bin/${_app_name}"
-
- install -Dm644 "${pkgdir}${_opt_app_dir}/data/flutter_assets/assets/icon.png" "${pkgdir}/usr/share/pixmaps/${_app_name}.png"
-
- install -dm755 "${pkgdir}/usr/share/applications"
- cat > "${pkgdir}/usr/share/applications/${_app_name}.desktop" << EOF
-[Desktop Entry]
-Type=Application
-Version=${pkgver//_/-}
-Name=Kaiteki
-Comment=A comfy Fediverse client for microblogging instances.
-Exec=/opt/${_app_name}/${_app_name}
-Icon=${_app_name}
-Terminal=false
-EOF
+provides=("${_pkgname}")
+depends=(
+ 'gtk3'
+ 'libhandy'
+ 'at-spi2-core'
+ 'cairo'
+ 'libepoxy'
+ 'pango'
+ 'gdk-pixbuf2'
+ 'fontconfig'
+)
+makedepends=(
+ 'gendesk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.zip::${_ghurl}/releases/download/weekly-${pkgver//_/-}/linux.zip"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/Kaiteki-Fedi/Kaiteki/weekly-${pkgver//_/-}/src/kaiteki/assets/icon.png"
+)
+sha256sums=('ab7d6f9b6a064d334db204ee6beb328b2457c71096ecbdcebaec94a270cd9957'
+ 'dc6b22558692d50f71113dbcbfed6382892cc2a27444cdacde03099297f36e3e')
+build() {
+ gendesk -q -f -n --categories "Network" --name="${_pkgname}" --exec="${pkgname%-bin} --no-sandbox %U"
+ chmod 755 "${srcdir}/linux/${pkgname%-bin}"
}
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/linux/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+} \ No newline at end of file
diff --git a/prepare_pkg.sh b/prepare_pkg.sh
deleted file mode 100755
index b050b8e9150d..000000000000
--- a/prepare_pkg.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env bash
-
-updpkgsums
-
-makepkg --printsrcinfo > .SRCINFO
-
-makepkg --install